您的位置:首页 > 其它

Poj.3100 Root of the Problem【水】 2015/09/22

2015-09-22 17:37 211 查看
Root of the Problem

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 11964Accepted: 6410
Description

Given positive integers B and N, find an integer A such that AN is as close as possible to B. (The result A is an approximation to the Nth root of B.) Note that AN may be less than, equal to, or greater than B.

Input

The input consists of one or more pairs of values for B and N. Each pair appears on a single line, delimited by a single space. A line specifying the value zero for both B and N marks the end of the input. The value of B will be in the range 1 to 1,000,000
(inclusive), and the value of N will be in the range 1 to 9 (inclusive).

Output

For each pair B and N in the input, output A as defined above on a line by itself.

Sample Input
4 3
5 3
27 3
750 5
1000 5
2000 5
3000 5
1000000 5
0 0

Sample Output
1
2
3
4
4
4
5
16

Source

Mid-Central USA 2006

同ZOJ2818

用G++提交,C++编译错误

,

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>

using namespace std;

int main(){
int n,b,a;
while( ~scanf("%d %d",&b,&n) ){
if( !b && !n ) break;
if( n == 1 )
printf("%d\n",b);
else if( n == 2 ){
a = (int)sqrt(b);
if( b-a*a > (a+1)*(a+1)-b )
printf("%d\n",a+1);
else printf("%d\n",a);
}
else{
int ret = 1000000,ans,res;
for( a = 1 ; a <= 100 ; ++a ){
ans = pow(a,n);
if( ret > fabs(b-ans) ){
ret = b-ans;
res = a;
}
if( ans > b ) break;
}
printf("%d\n",res);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: