您的位置:首页 > 其它

ZOJ.1938 Binomial Showdown【组合数】 2015/09/23

2015-09-23 16:40 218 查看
Binomial Showdown

Time Limit: 2 Seconds
Memory Limit: 65536 KB

In how many ways can you choose k elements out of n elements, not taking order into account?

Write a program to compute this number.

Input

The input will contain one or more test cases.

Each test case consists of one line containing two integers n (n >= 1) and k (0 <= k <= n).

Input is terminated by two zeroes for n and k.

Output

For each test case, print one line containing the required number. This number will always fit into an integer, i.e. it will be less than 2^31.

Sample Input

4 2

10 5

49 6

0 0

Sample Output

6

252

13983816

Source: University of Ulm Local Contest 1997

求C(n,k),但是要注意是C(n,k)快还是C(n,n-k)快

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>

using namespace std;

int min(int a,int b){
return a>b?b:a;
}

long long cal(int n,int k){
long long ret = 1;
k = min(k,n-k);
for( int i = 0 ; i < k ; ++i )
ret = (ret * (n-i) / (i+1) );
//    for( int i = 2 ; i <= k ; ++i )
//        ret /= i;
return ret;
}

int main(){
int n,k;
while( ~scanf("%d %d",&n,&k) ){
if( !n&&!k ) break;
printf("%lld\n",cal(n,k));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: