您的位置:首页 > 大数据 > 人工智能

hdoj 2674 N!Again

2015-09-20 11:09 483 查看

N!Again

[b]Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4152 Accepted Submission(s): 2232

[/b]

Problem Description
WhereIsHeroFrom: Zty, what are you doing ?

Zty: I want to calculate N!......

WhereIsHeroFrom: So easy! How big N is ?

Zty: 1 <=N <=1000000000000000000000000000000000000000000000…

WhereIsHeroFrom: Oh! You must be crazy! Are you Fa Shao?

Zty: No. I haven's finished my saying. I just said I want to calculate N! mod 2009

Hint : 0! = 1, N! = N*(N-1)!



Input
Each line will contain one integer N(0 <= N<=10^9). Process to end of file.



Output
For each case, output N! mod 2009



Sample Input
4 
5




Sample Output
24
120


题意: 2009 =7*7*41,所以输入超过41的数取余后得到0,输入0,时输出1;
对于小于41的同余定理求,即可!
代码:
#include<stdio.h>
int main()
{
	int i,j,n;
	char s[1010];
	while(scanf("%d",&n)!=EOF)
	{
		if(n>41)
		printf("0\n");
		else if(n==0)
		printf("1\n");
		else if(n<=41)
		{
			int sum=1;
			for(i=1;i<=n;i++)
			 {
			 	sum=(sum*(i%2009))%2009;
			 }
			 printf("%d\n",sum);
		}
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: