您的位置:首页 > 其它

poj1006 生理周期(中国剩余定理)

2015-09-15 14:37 253 查看
生理周期

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 122157Accepted: 38518
Description
人生来就有三个生理周期,分别为体力、感情和智力周期,它们的周期长度为23天、28天和33天。每一个周期中有一天是高峰。在高峰这天,人会在相应的方面表现出色。例如,智力周期的高峰,人会思维敏捷,精力容易高度集中。因为三个周期的周长不同,所以通常三个周期的高峰不会落在同一天。对于每个人,我们想知道何时三个高峰落在同一天。对于每个周期,我们会给出从当前年份的第一天开始,到出现高峰的天数(不一定是第一次高峰出现的时间)。你的任务是给定一个从当年第一天开始数的天数,输出从给定时间开始(不包括给定时间)下一次三个高峰落在同一天的时间(距给定时间的天数)。例如:给定时间为10,下次出现三个高峰同天的时间是12,则输出2(注意这里不是3)。
Input
输入四个整数:p, e, i和d。 p, e, i分别表示体力、情感和智力高峰出现的时间(时间从当年的第一天开始计算)。d 是给定的时间,可能小于p, e, 或 i。 所有给定时间是非负的并且小于365, 所求的时间小于21252。

当p = e = i = d = -1时,输入数据结束。
Output
从给定时间起,下一次三个高峰同天的时间(距离给定时间的天数)。

采用以下格式:

Case 1: the next triple peak occurs in 1234 days.

注意:即使结果是1天,也使用复数形式“days”。
Sample Input
0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1

Sample Output
Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.

Source
East Central North America 1999

题意:中文题,题意啥的就不多说了。
分析:典型的中国剩余定理题,答案就是(r1*p+r2*e+r3*k-d)%r,实在不知道怎么解释,如果懂中国剩余定理,这就是a+b的水题,不懂的话点这里

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a) memset(a,0,sizeof(a))

int p,e,k,d,sum;
int r1,r2,r3,r;

void slove()//求出r1,r2,r3,r;
{
    int i;
    for (i=1, r1=28*33; ; i++)
        if (r1*i%23==1) break;
    r1 *= i;
    for (i=1, r2=23*33; ; i++)
        if (r2*i%28==1) break;
    r2 *= i;
    for (i=1, r3=23*28; ; i++)
        if (r3*i%33==1) break;
    r3 *= i;
    r = 23*28*33;
}

int main ()
{
    int ii=1;
    slove();
    //cout<<r1<<" "<<r2<<" "<<r3<<" "<<r<<endl;
    while (scanf ("%d%d%d%d",&p,&e,&k,&d)==4)
    {
        if (p==-1&&e==-1&&k==-1&&d==-1)
            break;
        sum = (r1*p+r2*e+r3*k-d)%r;//中国剩余定理求解
        sum = (sum+r-1)%r+1;//可能会出现负数
        printf ("Case %d: the next triple peak occurs in %d days.\n",ii++, sum);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: