您的位置:首页 > 其它

hdoj 1028 Ignatius and the Princess III

2015-09-14 17:53 309 查看

Ignatius and the Princess III

[b]Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 16005 Accepted Submission(s): 11289

[/b]

Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:

N=a[1]+a[2]+a[3]+...+a[m];

a[i]>0,1<=m<=N;

My question is how many different equations you can find for a given N.

For example, assume N is 4, we can find:

4 = 4;

4 = 3 + 1;

4 = 2 + 2;

4 = 2 + 1 + 1;

4 = 1 + 1 + 1 + 1;

so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"



Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.



Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.



Sample Input
4
10
20




Sample Output
5
42
627[code]//次题所采用的多项式相乘的算法是先以第一个表达式的变量去遍历第二个表达式的变量 
#include<stdio.h>
#include<string.h>
#define N 1010
int main()
{
    int i,j,k;
    int c1
,c2
,n;//k代表指数,c1表示系数,c2做中间过度的变量 
    while(scanf("%d",&n)!=EOF)
    {
        for(i=0;i<=n;i++)
         {
             c1[i]=1;//初始化c1为1,代表第一个表达式的各个变量的系数皆为1
             c2[i]=0;
          } 
          for(i=2;i<=n;i++)//从第二个表达式开始,一共有n个表达式 
           {
               for(j=0;j<=n;j++)//J表示进行一次表达式相乘后,第一个表达式的的第J个变量
                for(k=0;k+j<=n;k+=i)// 此处表示第一个表达式的第J个变量遍历第二个表达式 (逻辑上的第I个表达式)
                 {
                     c2[j+k]+=c1[j];//C1[j]存储的是上一次运算结束后一个表达式中指数为j的系数,因为此时的第二个表达式的所有的系数均为1,其实就是将便利的过程中的拥有k+j指数的系数加1 
                }
                 for(k=0;k<=n;k++)
                 {
                     c1[k]=c2[k];//将c2 存储的系数赋值给相应的c1,然后清零c2, 
                     c2[k]=0;
                 }
           }
           printf("%d\n",c1
);
    }
    return 0;
 }

母函数知识点:/article/1850075.html

[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: