您的位置:首页 > 大数据 > 人工智能

UVA 573 The Snail

2015-09-12 21:19 351 查看
yiyi:有给测试数据, H 表示墙的高度 U表示白天能爬多少 D表示万事下降多少 F表示疲劳程度 (每天爬的高度都会减少H*F%) 蜗牛是不会往下爬的 要求输出 在第几天爬出 或者在第几天掉回原点。

成功>H 失败 < 0;

题目:

A snail is at the bottom of a 6-foot well and wants to climb to the top. The snail can climb 3 feet while the sun is up, but slides down 1 foot at night while sleeping. The snail has a fatigue factor of 10%, which means that on each successive day the snail
climbs 10%

3 = 0.3 feet less than it did the previous day. (The distance lost to fatigue is always 10% of the first day's
climbing distance.) On what day does the snail leave the well, i.e., what is the first day during which the snail's height exceeds 6 feet? (A day consists of a period of sunlight followed by a period of darkness.) As you can see from the
following table, the snail leaves the well during the third day.

DayInitial HeightDistance ClimbedHeight After ClimbingHeight After Sliding
10'3'3'2'
22'2.7'4.7'3.7'
33.7'2.4'6.1'-
Your job is to solve this problem in general. Depending on the parameters of the problem, the snail will eventually either leave the well or slide back to the bottom of the well. (In other words, the snail's height will exceed the height of the well or become
negative.) You must find out which happens first and on what day.


Input

The input file contains one or more test cases, each on a line by itself. Each line contains four integers H, U, D,
and F, separated by a single space. If H =
0 it signals the end of the input; otherwise, all four numbers will be between 1 and 100, inclusive. H is
the height of the well in feet, U is the distance
in feet that the snail can climb during the day, D is
the distance in feet that the snail slides down during the night, and F is
the fatigue factor expressed as a percentage. The snail never climbs
a negative distance. If the fatigue factor drops the snail's climbing distance below zero, the snail does not climb at all that day. Regardless of how far the snail climbed, it always slides Dfeet
at night.


Output

For each test case, output a line indicating whether the snail succeeded (left the well) or failed (slid back to the bottom) and on what day. Format the output exactly as shown in the example.


Sample Input

6 3 1 10
10 2 1 50
50 5 3 14
50 6 4 1
50 6 3 1
1 1 1 1
0 0 0 0



Sample Output

success on day 3
failure on day 4
failure on day 7
failure on day 68
success on day 20
failure on day 2


答案:
#include <iostream>
#include <stdio.h>
using namespace std;

int main () {
double H, U, D, F;
int term;
while (scanf("%lf%lf%lf%lf", &H, &U, &D, &F) != EOF) {
if (H == 0 && U == 0 && D == 0 && F == 0)
break;
term = 1;
double ini = 0;
double down = F * U / 100.0;
while (1) {
if (U > 0)
ini = ini + U;
if (ini > H) {
printf("success on day %d\n", term);
break;
}
ini = ini - D;
U = U - down;
if (ini < 0) {
printf("failure on day %d\n", term);
break;
}
term++;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: