您的位置:首页 > 运维架构

HDU 4349 Xiao Ming's Hope (Lucas定理的应用)

2015-09-07 07:30 316 查看

Xiao Ming's Hope

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1811 Accepted Submission(s): 1204

Problem Description

Xiao Ming likes counting numbers very much, especially he is fond of counting odd numbers. Maybe he thinks it is the best way to show he is alone without a girl friend. The day 2011.11.11 comes. Seeing
classmates walking with their girl friends, he coundn't help running into his classroom, and then opened his maths book preparing to count odd numbers. He looked at his book, then he found a question "C(n,0)+C(n,1)+C(n,2)+...+C(n,n)=?".
Of course, Xiao Ming knew the answer, but he didn't care about that , What he wanted to know was that how many odd numbers there were? Then he began to count odd numbers. When n is equal to 1, C(1,0)=C(1,1)=1, there are 2 odd numbers.
When n is equal to 2, C(2,0)=C(2,2)=1, there are 2 odd numbers...... Suddenly, he found a girl was watching him counting odd numbers. In order to show his gifts on maths, he wrote several big numbers what n would be equal to, but he found
it was impossible to finished his tasks, then he sent a piece of information to you, and wanted you a excellent programmer to help him, he really didn't want to let her down. Can you help him?

Input
Each line contains a integer n(1<=n<=108)

Output
A single line with the number of odd numbers of C(n,0),C(n,1),C(n,2)...C(n,n).

Sample Input

1
2
11



Sample Output

2
2
8



Author
HIT

Source
2012 Multi-University Training Contest 5


题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4349

题目大意:求C(n,i) (0 <= i <= n)中奇数的个数

题目分析:实际上就是求C(n, i) % 2 == 1的个数,应用Lucas定理,C(n, m) % p =C(n % p, m % p) * C(n / p, m / p),又因为C(0, 0) = 1, C(0, 1) = 0, C(1, 0) = 1, C(1, 1) = 1,可以发现如果C(n ,i)要为1,如果n的位置为0的话,m的位置必须是0,如果n的位置是1的话,m的位置可以为1或者0,设n中1的个数为cnt,则答案就是2^cnt,因为对每个n为1的位置,m有两种选择

#include <cstdio>

int main()
{
    int n;
    while(scanf("%d", &n) != EOF)
    {
        int cnt = 0;
        while(n)
        {
            cnt += (n & 1);
            n >>= 1;
        }
        printf("%d\n", 1 << cnt);
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: