您的位置:首页 > 其它

POJ 1523 SPF (无向图求割点 tarjan算法)

2015-09-07 23:53 369 查看
SPF
Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 7147Accepted: 3262
Description
Consider the two networks shown below. Assuming that data moves around these networks only between directly connected nodes on a peer-to-peer basis, a failure of a single node, 3, in the network on
the left would prevent some of the still available nodes from communicating with each other. Nodes 1 and 2 could still communicate with each other as could nodes 4 and 5, but communication between any other pairs of nodes would no longer be possible.

Node 3 is therefore a Single Point of Failure (SPF) for this network. Strictly, an SPF will be defined as any node that, if unavailable, would prevent at least one pair of available nodes from being able to communicate on what was previously a fully connected
network. Note that the network on the right has no such node; there is no SPF in the network. At least two machines must fail before there are any pairs of available nodes which cannot communicate.



Input
The input will contain the description of several networks. A network description will consist of pairs of integers, one pair per line, that identify connected nodes. Ordering of the pairs is irrelevant;
1 2 and 2 1 specify the same connection. All node numbers will range from 1 to 1000. A line containing a single zero ends the list of connected nodes. An empty network description flags the end of the input. Blank lines in the input file should be ignored.
Output
For each network in the input, you will output its number in the file, followed by a list of any SPF nodes that exist.

The first network in the file should be identified as "Network #1", the second as "Network #2", etc. For each SPF node, output a line, formatted as shown in the examples below, that identifies the node and the number of fully connected subnets that remain when
that node fails. If the network has no SPF nodes, simply output the text "No SPF nodes" instead of a list of SPF nodes.
Sample Input
1 2
5 4
3 1
3 2
3 4
3 5
0

1 2
2 3
3 4
4 5
5 1
0

1 2
2 3
3 4
4 6
6 3
2 5
5 1
0

0

Sample Output
Network #1
  SPF node 3 leaves 2 subnets

Network #2
  No SPF nodes

Network #3
  SPF node 2 leaves 2 subnets
  SPF node 3 leaves 2 subnets

Source
Greater New York 2000

题目链接:http://poj.org/problem?id=1523

题目大意:无向图求割点和去除割点后连通分量的个数

题目分析:裸题,Tarjan算法直接搞

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int const MAX = 1005;
bool vis[MAX];
int head[MAX];
int low[MAX], dfn[MAX], subnet[MAX];
int cnt, ma, tmpdfn, son;

struct EGDE
{
    int v, next;
}e[MAX];

void Add(int u, int v)
{
    e[cnt].v = v;
    e[cnt].next = head[u];
    head[u] = cnt ++;
}

void Init()
{
    ma = 0;
    son = 0;
    cnt = 0;
    tmpdfn = 1;
    memset(head, -1, sizeof(head));
    memset(vis, false, sizeof(vis));
    memset(low, 0, sizeof(low));
    memset(dfn, 0, sizeof(dfn));
    memset(subnet, 0, sizeof(subnet));
}

void DFS(int u)
{
    vis[u] = true;
    for(int i = head[u]; i != -1; i = e[i].next) 
    {
        int v = e[i].v;
        if(!vis[v])
        {
            tmpdfn ++;
            low[v] = tmpdfn;
            dfn[v] = tmpdfn;
            DFS(v);
            low[u] = min(low[u], low[v]);
            if(low[v] >= dfn[u])
                (u == 1) ? son ++ : subnet[u] ++;
        }
        else
            low[u] = min(low[u], dfn[v]);
    }
}

int main()
{
    int u, v, ca = 1;
    while(scanf("%d", &u) != EOF && u)
    {
        Init();
        scanf("%d", &v);
        Add(u, v);
        Add(v, u);
        ma = max(ma, max(u, v));    
        while(scanf("%d", &u) != EOF && u)
        {
            scanf("%d", &v);
            Add(u, v);
            Add(v, u);
            ma = max(ma, max(u, v));    
        }
        DFS(1);
        if(son > 1)
            subnet[1] = son - 1;
        printf("Network #%d\n", ca ++);
        bool flag = false;
        for(int i = 1; i <= ma; i++)
        {
            if(subnet[i])
            {
                flag = true;
                printf("  SPF node %d leaves %d subnets\n", i, subnet[i] + 1);
            }
        }
        if(!flag)
            printf("  No SPF nodes\n");
        printf("\n");
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: