您的位置:首页 > 其它

NBUT 1218 You are my brother

2015-09-05 18:08 344 查看
Little A gets to know a new friend, Little B, recently. One day, they realize that they are family 500 years ago. Now, Little A wants to know whether Little B is
his elder, younger or brother.

Input
There are multiple test cases.

For each test case, the first line has a single integer, n (n<=1000). The next n lines have two integers a and b (1<=a,b<=2000) each, indicating b is the father of a. One person has exactly one father, of course. Little A is numbered 1 and Little B is numbered
2.

Proceed to the end of file.

Output
For each test case, if Little B is Little A’s younger, print “You are my younger”. Otherwise, if Little B is Little A’s elder, print “You are my elder”. Otherwise, print “You are my brother”. The output for each test case occupied exactly
one line.

Sample Input

5
1 3
2 4
3 5
4 6
5 6
6
1 3
2 4
3 5
4 6
5 7
6 7


Sample Output

You are my elder
You are my brother


找祖先 看谁辈份大

#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std;

int main()
{
int la,lb,a,b,n,x,y,s1,s2;
while(scanf("%d",&n)!=EOF)
{
la=1;lb=2;s1=0;s2=0;
for(int i=0; i<n; i++)
{
scanf("%d%d",&x,&y);
if(la!=lb)
{
if(x==la)
{
la=y;
s1++;
}
if(x==lb)
{
lb=y;
s2++;
}
}
}
if(s1<s2)       printf("You are my younger\n");
else if(s1==s2) printf("You are my brother\n");
else if(s1>s2)  printf("You are my elder\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: