您的位置:首页 > 其它

HDU 2608 0 or 1 简单数论

2015-09-04 20:24 274 查看

题目:

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2608

Problem Description

Solving problem is a interesting thing. Yifenfei like to slove different problem,because he think it is a way let him more intelligent. But as we know,yifenfei is weak in math. When he come up against a difficult math problem, he always try to get a hand. Now the problem is coming! Let we

define T(n) as the sum of all numbers which are positive integers can divied n. and S(n) = T(1) + T(2) + T(3)…..+T(n).

Input

The first line of the input contains an integer T which means the number of test cases. Then T lines follow, each line consists of only one positive integers n. You may assume the integer will not exceed 2^31.

Output

For each test case, you should output one lines of one integer S(n) %2. So you may see the answer is always 0 or 1 .

Sample Input

3

1

2

3

Sample Output

1

0

0

Hint

Hint S(3) = T(1) + T(2) +T(3) = 1 + (1+2) + (1+3) = 8

S(3) % 2 = 0

分析:

赶脚这题非常坑。

打了一个S数组的表,简单yy了一下,什么卵都没发现。

后来有大神告诉我打T数组的表:

T=1的有1 2 4 8 9 16 18 25 32 36 49 50 64 72 81 98 100

简单yy了一下发现:

1.当n是完全平方数时T=1;

2.当n/2是完全平方数时T=1;

然后瞬间AC。

我的A(yang)C(wei)代码

#include <cstdio>
#include <cmath>
#include <iostream>
#include <algorithm>
using namespace std;
int T;
int main(){
cin >> T;
while (T--){
int n;
cin >> n;
int ans=0;
for (int i=1;;i++){
if (i*i<=n) ans++;
if (i*i*2<=n) ans++;
if (i*i>n) break;
}
cout << ans%2 << endl;
}
return 0;
}


大神的代码

#include <iostream>
#include <cmath>
using namespace std;
int main(){
int t;
cin >> t;
while (t--)
{
int n;
cin >> n;
int ans=(int)sqrt(n*1.0)+(int)sqrt(n*1.0/2);
cout << ans%2 << endl;
}
return 0;
}


附打表代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int calc(int x){
int tot=0;
for (int j=1;j<=x;j++){
if (x%j==0) tot+=j;
}
return tot;
}
int main(){
int t=0;
for (int i=1;i<=100;i++){
t=calc(i);printf("%d %d\n",i,t%2);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: