您的位置:首页 > 其它

PAT (Advanced Level) Practise:1008. Elevator

2015-09-01 11:01 357 查看
【题目链接】

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

提交代码:

#include <stdio.h>

int main(void)
{
int N;
int i, pre, cur;
int delta;
int time;

pre = 0;
time = 0;
scanf("%d", &N);
for(i = 0; i < N; i++)
{
scanf("%d", &cur);
if(cur - pre >= 0)
{
delta = cur - pre;
time += (delta * 6);
}
else
{
delta = pre - cur;
time += (delta * 4);
}
pre = cur;
}
printf("%d", time + N * 5);

return 0;
}


运行结果:

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: