您的位置:首页 > 大数据 > 人工智能

UVA10976 Fractions Again?!

2015-08-28 09:37 375 查看

It is easy to see that for every fraction in the form 1

k

(k > 0), we can always find two positive integers

x and y, x ≥ y, such that:

1

k

=

1

x

+

1

y

Now our question is: can you write a program that counts how many such pairs of x and y there

are for any given k?

Input

Input contains no more than 100 lines, each giving a value of k (0 < k ≤ 10000).

Output

For each k, output the number of corresponding (x, y) pairs, followed by a sorted list of the values of

x and y, as shown in the sample output.

Sample Input

2

12

Sample Output

2

1/2 = 1/6 + 1/3

1/2 = 1/4 + 1/4

8

1/12 = 1/156 + 1/13

1/12 = 1/84 + 1/14

1/12 = 1/60 + 1/15

1/12 = 1/48 + 1/16

1/12 = 1/36 + 1/18

1/12 = 1/30 + 1/20

1/12 = 1/28 + 1/21

1/12 = 1/24 + 1/24

根据x与y的关系,推算出y的范围,然后在【k+1,2*k】枚举y值,利用等式推出求解出x然后判断x是否是整数,或者是否能整除

为了提高效率可以将结果保存在数组中,然后输出数组的结果;

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int main()
{
    int k;
    while(scanf("%d",&k)!=EOF)
    {
        double x;
        int num=0;
        for(int i=k+1;i<=2*k;i++)
        {
            x=k*i*1.0/(i-k);
            if((int)x==x && x>=i && x>k)
                num++;
        }
        printf("%d\n",num);
        for(int i=k+1;i<=2*k;i++)
        {
            x=k*i*1.0/(i-k);
            if((int)x==x && x>=i && x>k)
                printf("1/%d = 1/%d + 1/%d\n",k,(int)x,i);
        }
    }

    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: