您的位置:首页 > 其它

POJ 1426 Find The Multiple

2015-08-25 16:48 337 查看
D - Find The Multiple
Time Limit:1000MS Memory Limit:10000KB 64bit IO Format:%I64d
& %I64u
SubmitStatusPracticePOJ
1426

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing
no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them
is acceptable.

Sample Input

2
6
19
0


Sample Output

10
100100100100100100
111111111111111111


BFS搜索。

题目大概意思是给一个数n,让你找出一个只有1,0,组成的十进制数,要求是找到的数可以被n整除。不能超过100个数字。输出一个满足的数组即可。

假如n=6;

1余n=1;

10余n=1*10%6=4;

11余n=(1*10+1)%6=5;

100余n=4*10%6=4;

101余n=(4*10+1)%6=5;

110余n=5*10%6=2;

111余n=(5*10+1)%6=3;

可以推知10........01余n=(10.........0余n*10+1)余n;

当然这个搜索的效率貌似不高。438ms.

#include<stdio.h>
#include<queue>
using namespace std;
void bfs(int n)
{
queue<long long>q;
q.push(1);
while(!q.empty())
{
long long x;
x=q.front();
q.pop();
if(x%n==0)
{
printf("%lld\n",x);
return ;
}
q.push(x*10);
q.push(x*10+1);
}
}
int main()
{
int n;
while(scanf("%d",&n)>0&&n)
{
bfs(n);
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: