您的位置:首页 > 大数据 > 人工智能

1090. Highest Price in Supply Chain (25) -计层的BFS改进

2015-08-24 18:24 399 查看
题目如下:

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root
supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence they are numbered from 0 to N-1); P, the price
given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number Si is the index of the supplier for the i-th member. Sroot for
the root supplier is defined to be -1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the
price will not exceed 1010.

Sample Input:
9 1.80 1.00
1 5 4 4 -1 4 5 3 6

Sample Output:
1.85 2


题目要求根据供应链条计算最深层的零售商的售价,实质是图的BFS,并且BFS要记录层级,这道题和之前的一道1079. Total Sales of Supply Chain (25)算法一致,这里不再赘述。唯一的不同是图的输入,并且根结点不再固定是0。

代码如下:

#include <iostream>
#include <vector>
#include <stdio.h>
#include <queue>
#include <math.h>

using namespace std;

int main()
{
vector<vector<int> > graph;
int N;
double P,r;
cin >> N >> P >> r;
graph.resize(N);
int num;
int root;
for(int i = 0; i < N; i++){
scanf("%d",&num);
if(num == -1){
root = i;
continue;
}
graph[num].push_back(i);
}
queue<int> q;
q.push(root);
int level = 0;
int last,tail;
last = tail = root;
int maxLevel = 0;
int cnt = 0;
while(!q.empty()){
int v = q.front();
q.pop();
if(level == maxLevel){
cnt++;
}else if(level > maxLevel){
maxLevel = level;
cnt = 1;
}
for(int i = 0; i < graph[v].size(); i++){
int w = graph[v][i];
q.push(w);
tail = w;
}
//printf("(%d)->%d\n",level,v);
if(v == last){
last = tail;
level++;
if(level > 1) P*= (100+r)/100;
}

}
printf("%.2lf %d\n",P,cnt);

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: