您的位置:首页 > 其它

HDU 1036.Average is not Fast Enough!【精度及格式控制】【8月23】

2015-08-23 16:49 162 查看
Average is not Fast Enough!

Problem Description

A relay is a race for two or more teams of runners. Each member of a team runs one section of the race. Your task is to help to evaluate the results of a relay race.

You have to process several teams. For each team you are given a list with the running times for every section of the race. You are to compute the average time per kilometer over the whole distance. That's easy, isn't it?

So if you like the fun and challenge competing at this contest, perhaps you like a relay race, too. Students from Ulm participated e.g. at the "SOLA" relay in Zurich, Switzerland. For more information visit http://www.sola.asvz.ethz.ch/ after the contest is
over.

Input

The first line of the input specifies the number of sections n followed by the total distance of the relay d in kilometers. You may safely assume that 1 <= n <= 20 and 0.0 < d < 200.0. Every following line gives information about one team: the team number t
(an integer, right-justified in a field of width 3) is followed by the n results for each section, separated by a single space. These running times are given in the format "h:mm:ss" with integer numbers for the hours, minutes and seconds, respectively. In
the special case of a runner being disqualified, the running time will be denoted by "-:--:--". Finally, the data on every line is terminated by a newline character. Input is terminated by EOF.

Output

For each team output exactly one line giving the team's number t right aligned in a field of width 3, and the average time for this team rounded to whole seconds in the format "m:ss". If at least one of the team's runners has been disqualified, output "-" instead.
Adhere to the sample output for the exact format of presentation.

Sample Input

2 12.5
5 0:23:21 0:25:01
42 0:23:32 -:--:--
7 0:33:20 0:41:35


Sample Output

5: 3:52 min/km
42: -
7: 6:00 min/km


一共n圈,d千米。如样例,编号为5的两圈时间分别为 0:23:21 0:25:01 ,求出他一分钟多少千米,及min/km 。浮点型数据有误差,计算过程要注意精度控制。代码如下:
#include<cstdio>
int main(){
int q,h;
double z;
scanf("%d%lf",&q,&z);
while(scanf("%d",&h)==1){
double sum=0;
bool key=true;
char s[10];
printf("%3d:",h);
for(int i=0;i<q;i++){
scanf("%s",s);
if(s[0]!='-'&&key)
sum+=(s[0]-'0')*3600+((s[2]-'0')*10+s[3]-'0')*60+(s[5]-'0')*10+(s[6]-'0');
else key=false;
}
if(key){
int x=((sum/z+0.5)/60);
int y=(int)(sum/z+0.5)%60;
printf("%2d:%02d min/km\n",x,y);//格式。因为格式PE一次
}
else printf(" -\n");//格式
}
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: