您的位置:首页 > 其它

HDU 1037.Keep on Truckin'【水水水(重要事情说三遍)】【8月23】【记录】

2015-08-23 17:06 162 查看
Keep on Truckin'

Problem Description

Boudreaux and Thibodeaux are on the road again . . .

"Boudreaux, we have to get this shipment of mudbugs to Baton Rouge by tonight!"

"Don't worry, Thibodeaux, I already checked ahead. There are three underpasses and our 18-wheeler will fit through all of them, so just keep that motor running!"

"We're not going to make it, I say!"

So, which is it: will there be a very messy accident on Interstate 10, or is Thibodeaux just letting the sound of his own wheels drive him crazy?

Input

Input to this problem will consist of a single data set. The data set will be formatted according to the following description.

The data set will consist of a single line containing 3 numbers, separated by single spaces. Each number represents the height of a single underpass in inches. Each number will be between 0 and 300 inclusive.

Output

There will be exactly one line of output. This line will be:

NO CRASH

if the height of the 18-wheeler is less than the height of each of the underpasses, or:

CRASH X

otherwise, where X is the height of the first underpass in the data set that the 18-wheeler is unable to go under (which means its height is less than or equal to the height of the 18-wheeler).

The height of the 18-wheeler is 168 inches.

Sample Input

180 160 170


Sample Output

CRASH 160


直接看代码:
#include<cstdio>
int main(){
int a,b,c,minx,maxn;
while(scanf("%d%d%d",&a,&b,&c)==3){
minx=a>b?b:a;
minx=minx>c?c:minx;
if(minx<168) printf("CRASH %d\n",minx);
else printf("NO CRASH\n");
}
return 0;
}



另外记录一下最近在HDU A题的情况:

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: