您的位置:首页 > 其它

PAT 1059. Prime Factors (25)

2015-08-22 14:56 543 查看


1059. Prime Factors (25)

时间限制

50 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

HE, Qinming

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1^k1 * p2^k2 *…*pm^km.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p1^k1 * p2^k2 *…*pm^km, where pi's
are prime factors of N in increasing order, and the exponent ki is the number of pi -- hence when there is only one pi, ki is
1 and must NOT be printed out.
Sample Input:
97532468

Sample Output:
97532468=2^2*11*17*101*1291


这道题是分解质因数问题。输入正整数N,将其拆分为质数乘积。我的做法是一开始先找到所有从2到根号N内的质数,然后依次试除这些数并计数,然后按照要求的格式输出就行了。代码如下:

#include <iostream>
#include <cmath>
using namespace std;
int prime[100000];
bool judge(long int x)
{
if(x==2)
return true;
int i;
for(i=2;i<=sqrt(x);i++)
if(x%i==0)
break;
if(i>sqrt(x))
return true;
else
return false;
}
int getprime(long int n)
{
long int i;
int j=0;
for(i=2;i<=sqrt(n);i++)
if(judge(i))
prime[j++]=i;
return j;
}
int main()
{
long int N;
cin>>N;
long int n=N;
int size=getprime(N);
cout<<N<<"=";
if(judge(N))
{
cout<<N;
return 0;
}
for(int i=0;i<size;i++)
{
int count=0;
for(;n%prime[i]==0;)
{
n/=prime[i];
count++;
}
if(judge(n))
{
if(n>=2)
{
if(count==1)
cout<<prime[i]<<"*"<<n;
else if(count>1)
cout<<prime[i]<<"^"<<count<<"*"<<n;
}
else
{
if(count==1)
cout<<prime[i];
else if(count>1)
cout<<prime[i]<<"^"<<count;
}
break;
}
if(count==1)
cout<<prime[i]<<"*";
else if(count>1)
cout<<prime[i]<<"^"<<count<<"*";

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: