您的位置:首页 > 其它

HDU 2058 The sum problem Time (等差和推理之类数学题)

2015-08-22 00:03 525 查看

The sum problem

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 18728 Accepted Submission(s): 5561



[align=left]Problem Description[/align]
Given a sequence 1,2,3,......N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.

[align=left]Input[/align]
Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.

[align=left]Output[/align]
For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.

[align=left]Sample Input[/align]

20 10
50 30
0 0


[align=left]Sample Output[/align]

[1,4]
[10,10]

[4,8]
[6,9]
[9,11]
[30,30]
//分析:题目第一眼看上去就知不能暴力貌似也不能打表  第一次用Sn=(a1+an)*n/2  发现得遍历2个  估计超时后来  Sn=na1+n(n-1)d/2当a1=1时  得到最长的长度N 又在a1=1时  2Sn=n(n+1)=2*m  所以n<=sqrt(2*m)  遍历n=[1,sqrt(2*m)]  求得a1  在判断an超不超n 并且判断等差求和公式等不等于m  因为害怕除法时有浮点不一致了
#include <iostream>
#include <cstdio>
#include <math.h>
#include <string.h>
#include <string>
#include <algorithm>
#include <iomanip>
#include <stdlib.h>
using namespace std;
int main(){
int n,m,i,a1,an;
while(cin>>n>>m){
if(n==0&&m==0)
break;
for(i=sqrt(2*m);i>=1;i--){
a1=(2*m-i*i+i)/(2*i);
an=a1+(i-1);
if(an<=n&&(a1+an)*i==2*m)
cout<<"["<<a1<<","<<an<<"]"<<endl;
}
cout<<endl;
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: