您的位置:首页 > 其它

HDU 1075 What Are You Talking About(map+字符串)

2015-08-29 18:27 274 查看

What Are You Talking About

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 102400/204800 K (Java/Others)

Total Submission(s): 17575 Accepted Submission(s): 5724



[align=left]Problem Description[/align]
Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book
into English. Can you help him?

[align=left]Input[/align]
The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines
follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book
part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate
it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated.
A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.

[align=left]Output[/align]
In this problem, you have to output the translation of the history book.

[align=left]Sample Input[/align]

START
from fiwo
hello difh
mars riwosf
earth fnnvk
like fiiwj
END
START
difh, i'm fiwo riwosf.
i fiiwj fnnvk!
END


[align=left]Sample Output[/align]

hello, i'm from mars.
i like earth!

Hint
Huge input, scanf is recommended.

//STL太强大了...
#include <iostream>
#include <cstdio>
#include <string>
#include <string.h>
#include <map>
using namespace std;
map<string,string> ma;
int main(){
int i;
char word1[12],word2[12];
string s,tmp;
scanf("%s",word1);
while(scanf("%s",word1)==1){
if(word1[0]=='E'&&word1[1]=='N'&&word1[2]=='D'&&strlen(word1)==3)
break;
scanf("%s",word2);
ma[word2]=word1;
}
scanf("%s",word1);
char c=getchar();
while(getline(cin,s)){
if(s=="END")
break;
tmp="";
for(i=0;s[i]!='\0';i++){
if((s[i]>='a'&&s[i]<='z')||(s[i]>='A'&&s[i]<='Z'))
tmp+=s[i];
else
{
if(ma.count(tmp)!=0)
cout<<ma[tmp];
else
cout<<tmp;
printf("%c",s[i]);
tmp="";
}
}
printf("\n");
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: