您的位置:首页 > 其它

Cash Machine(POJ--1276 【多重背包】

2015-08-19 11:22 399 查看
Description
A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount.
The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.

Notes:

@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.

Input
The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:

cash N n1 D1 n2 D2 ... nN DN

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers
in the input. The input data are correct.

Output
For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.

题意:给你n种钱币,c[i]表示第i种钱币的数量,w[i]表示第i种钱币的面值,求用这n种钱组合成小于或等于cash 的金额。
思路:这是一个多重背包问题。
Sample Input
735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output
735
630
0
0

Hint
The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4
bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash.

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered
cash.

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <queue>
#define MAX 0x3f3f3f3f
using namespace std;
int dp[100005],c[20],w[20],cash;
void complete(int vi,int wi)       //完全背包
{
for(int i=vi; i<=cash; i++)    //背包容量从小到大遍历,因为该状态之前的状态是该物品已更新完的状态
dp[i]=max(dp[i],dp[i-wi]+wi);
}
void ze(int vi,int wi)       //01背包
{
for(int i=cash; i>=vi; i--)    //背包容量从大到小遍历,因为该状态之前的状态是上一个物品已更新完的状态(如果从小到大遍历的话,那么该物品可能在该状态之前就已经放入背包了,那现在就不能再放了,或可能会放重)
dp[i]=max(dp[i],dp[i-wi]+wi);
}
int main()
{
//freopen("lalala.text","r",stdin);
int n;
while(~scanf("%d %d",&cash,&n))
{
for(int i=1; i<=n; i++)
{
scanf("%d %d",&c[i],&w[i]);
}
if(cash==0||n==0)
{
printf("0\n");
continue;
}
memset(dp,0,sizeof(dp));
for(int i=1; i<=n; i++)
{
if(c[i]*w[i]>cash)   //如果该种面值所有的金额大于cash则该题可转化为以该种面值为某物体的体积和价值,求得能放入背包最大价值的完全背包
complete(w[i],w[i]);
else                    //否则就可以转化为01背包
{
int k=1;
while(k<c[i])    //只有将物品件数按二进制拆分才能将1~n的所有件数全部枚举一遍
{
ze(w[i]*k,w[i]*k);
c[i]-=k;
k*=2;
}
ze(c[i]*w[i],c[i]*w[i]);
}
}
printf("%d\n",dp[cash]);
}
return 0;
}<strong>
</strong>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: