您的位置:首页 > 其它

POJ 3685 Matrix(二分套二分)

2015-08-18 21:18 375 查看
http://poj.org/problem?id=3685

Matrix

Time Limit: 6000MSMemory Limit: 65536K
Total Submissions: 5329Accepted: 1452
Description

Given a N × N matrix A, whose element in the
i-th row and j-th column Aij is an number that equals
i2 + 100000 × i + j2 - 100000 ×
j + i × j, you are to find the M-th smallest element in the matrix.

Input

The first line of input is the number of test case.

For each test case there is only one line contains two integers, N(1 ≤
N ≤ 50,000) and M(1 ≤ M ≤ N × N). There is a blank line before each test case.

Output

For each test case output the answer on a single line.

Sample Input
12

1 1

2 1

2 2

2 3

2 4

3 1

3 2

3 8

3 9

5 1

5 25

5 10

Sample Output
3
-99993
3
12
100007
-199987
-99993
100019
200013
-399969
400031
-99939


题目大意:题目意思很简单。这个题目乍一看,先打n为比较小例如8的表,会觉得很有规律,

大小规律是从右上往左下依次增大,但是这个规律到n为5*10^4就不一定保持了。


解题思路:有一个规律是看得见的,j不变i增大函数值也在增大。很多人可能跟我一样,无从入手,
既不知道要跟谁比较,跟不知道哪个值是我们所求位置的值。那么我们可以随便假设一
个值ans(在这ans=(-1e12+1e12)/2),用第二层二分求出其值的大小位置为X,再跟m比
较,就这样,然一个值的大小位置X不断逼近m。我处理得到最后的结果个数为m+1的最
小值,所以最后要mid-1即为答案。


#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>

using namespace std;
typedef long long LL;
const LL maxnn=100000;

LL n,m;
LL comput(LL i,LL j)
{
   return  i*i+maxnn*i+j*j-maxnn*j+i*j;
}
LL two(LL x)
{
    LL ans=0,left,right,mid;
    for(int i=1;i<=n;i++)
    {
        left=1,right=n+1;
        mid=(left+right)>>1;
        while(left<right)
        {
            if(comput(mid,i)>=x) right=mid;
            else left=mid+1;
            mid=(left+right)>>1;
        }
        ans +=mid-1;
    }
    return ans;
}
int main()
{
    LL T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%lld %lld",&n,&m);
        LL left=-1e12,right=1e12;
        LL mid=(left+right)>>1;
        while(left<right)
        {
            if(two(mid)>=m) right=mid;
            else left=mid+1;
            mid=(left+right)>>1;
        }
        printf("%lld\n",mid-1);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: