您的位置:首页 > 其它

HDOJ Choose the best route (最短路倒着构图Dijkstra)

2015-08-18 21:15 489 查看

Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 10599    Accepted Submission(s): 3413


[align=left]Problem Description[/align]
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s
home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

 

[align=left]Input[/align]
There are several test cases.

Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands
for the bus station that near Kiki’s friend’s home.

Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .

Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.

 

 

[align=left]Output[/align]
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

 

[align=left]Sample Input[/align]

5 8 5
1 2 2
1 5 3
1 3 4
2 4 7
2 5 6
2 3 5
3 5 1
4 5 1
2
2 3
4 3 4
1 2 3
1 3 4
2 3 2
1
1

 

 

[align=left]Sample Output[/align]

1
-1

 

 

[align=left]Author[/align]
dandelion
 

 

[align=left]Source[/align]
2009浙江大学计算机研考复试(机试部分)——全真模拟
 

/*这道题的意思是,有几个出发点,只有一个终点,问从哪个出发点到终点的距离最短,所以倒着构图比较方便,可以转化成一个起点,几个终点*/

/*而且,这个图是个单向图*/

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define max 0x3f3f3f3f
int map[1100][1100],sign[1100],dis[1100];
int n,m;
void Dijk(int s)
{
int i,j,t;
for (i=1;i<=n;i++)
{
sign[i]=0;
dis[i]=max;
}
dis[s]=0;
while (1)
{
t=-1;
for (i=1;i<=n;i++)
if (!sign[i]&&(t==-1||dis[i]<dis[t]))
t=i;
if (t==-1)
break;
sign[t]=1;
for (j=1;j<=n;j++)
dis[j]=min(dis[j],dis[t]+map[t][j]);
}
}
int main()
{
int s;
while (scanf ("%d%d%d",&n,&m,&s)!=EOF)
{
int i,j;
for (i=1;i<=n;i++)
for (j=1;j<=n;j++)
{
if (i==j)
map[i][j]=0;
else
map[i][j]=map[j][i]=max;
}
int a,b,c;
for (i=0;i<m;i++)
{
scanf ("%d%d%d",&a,&b,&c);
if (map[b][a]>c)
map[b][a]=c;//倒着构图
}
int w,k;
scanf ("%d",&w);
int minp=max;
Dijk(s);
while (w--)
{
scanf ("%d",&k);
minp=min(minp,dis[k]);
}
if (minp==max)
printf ("-1\n");
else
printf("%d\n",minp);
}
return 0;


 

 

 

 

 

 

 

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: