您的位置:首页 > 其它

Eddy's digital Roots HDU杭电1163 【一个比较实用的定理】

2015-08-18 21:11 465 查看
Problem Description

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is
repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process
must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

The Eddy's easy problem is that : give you the n,want you to find the n^n's digital Roots.



Input

The input file will contain a list of positive integers n, one per line. The end of the input will be indicated by an integer value of zero. Notice:For each integer in the input n(n<10000).



Output

Output n^n's digital root on a separate line of the output.



Sample Input

2
4
0




Sample Output

4
4




#include<stdio.h>
int main()
{
	int n;
	int pos;
	while(scanf("%d",&n),n)
	{
		int res=1;
		for(int i=1;i<=n;++i)
		{
			res*=n;
			res=res%9==0?9:res%9;
		}
		printf("%d\n",res);
	}
	return 0;
}

/*

因为ab*ab=(10*a+b)*(10*a+b)=100*a*a+10*2*a*b+b*b=a*a+2*a*b+b*b=(a+b)*(a+b)
abc*abc=(100*a+10*b+c)*(100*a+10*b+c)
=10000*a*a+2000*a*b+100*b*b+200*a*c+20*b*c+c*c
=a*a+2*a*b+b*b+2*a*c+2*b*c+c*c
=(a+b)^2+2*c*(a+b)+c*c
= (a+b+c)*(a+b+c)

所以((a+b+c)*(a+b+c))%9=((abc)%9*(abc)%9)%9 同余定理 
*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: