您的位置:首页 > 产品设计 > UI/UE

Children’s Queue 1297 (大数)

2015-08-18 19:18 477 查看

Children’s Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 12453    Accepted Submission(s): 4066


[align=left]Problem Description[/align]
There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one
girl stands side by side. The case n=4 (n is the number of children) is like

FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM

Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?

 

[align=left]Input[/align]
There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)

 

[align=left]Output[/align]
For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.
 

[align=left]Sample Input[/align]

1
2
3

 

[align=left]Sample Output[/align]

1
2
//现列举前几项,找出规律,a[i]=a[i-1]+a[i-2]+a[i-4].......
//然后就是一大数模板了。
#include<stdio.h>
#include<string.h>
int a[1010][1010];
int main(){
int i,j,n,m;
a[0][1000]=0;a[1][1000]=1;a[2][1000]=2;a[3][1000]=4;a[4][1000]=7;
for(i=5;i<=1000;i++)
{
for(j=1000;j>=0;j--)
{
a[i][j]+=a[i-1][j]+a[i-2][j]+a[i-4][j];
if(a[i][j]>=10)
{
a[i][j-1]+=a[i][j]/10;
a[i][j]=a[i][j]%10;
}
}
}
while(scanf("%d",&n)!=EOF)
{
for(i=0;i<=1000;i++)
if(a
[i]!=0)
break;
m=i;
for(i=m;i<=1000;i++)
printf("%d",a
[i]);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: