您的位置:首页 > 其它

hdu2647(拓扑排序)

2015-08-18 19:17 260 查看
Description

Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.

The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward
will be at least 888 , because it's a lucky number.

Input

One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)

then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.

Output

For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.

Sample Input

2 1
1 2
2 2
1 2
2 1


Sample Output

1777
-1


鉴于还不是很会邻接表,我用的有点暴力的办法建立的结构体呜呜呜呜呜~~~~~~~~~

幸好这题数据并不大,如果大些真的是要哭了。。。邻接表很重要呀!!!

反向建图算层数,最后的处理仔细看代码很容易看懂的。

代码:

#include <string.h>
#include <stdio.h>
#include <algorithm>
#include <iostream>
using namespace std;
struct data
{
int tal,rd,mem[15],cs;

}a[10010];

int bfs(int n)
{
int x=0;
while(x<n)
{
int flag=0;
for(int i=1;i<=n;i++)
{
if(a[i].rd==0)
{
a[i].rd--;
int tem=a[i].cs+1;
for(int j=0;j<a[i].tal;j++)
{
a[a[i].mem[j]].rd--;
a[a[i].mem[j]].cs=max(tem,a[a[i].mem[j]].cs);
}
flag=1;
x++;
}
}
if(flag==0)return 0;
}
return 1;
}

int main()
{
int m,n;
while(~scanf("%d%d",&n,&m))
{
memset(a,0,sizeof(a));
for(int i=0; i<m; i++)
{
int t1,t2;
scanf("%d%d",&t1,&t2);
a[t1].rd++;
a[t2].mem[a[t2].tal++]=t1;
}
int t=bfs(n);
if(t==0)printf("-1\n");
else
{
int s=888*n;
for(int i=1;i<=n;i++)
s+=a[i].cs;
printf("%d\n",s);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: