您的位置:首页 > 其它

HUD 1058 Humble Numbers

2015-08-18 18:07 295 查看
HUD 1058 Humble Numbers

Problem Description

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, … shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence

Input

The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line saying “The nth humble number is number.”. Depending on the value of n, the correct suffix “st”, “nd”, “rd”, or “th” for the ordinal number nth has to be used like it is shown in the sample output.

Sample Input

1

2

3

4

11

12

13

21

22

23

100

1000

5842

0

Sample Output

The 1st humble number is 1.

The 2nd humble number is 2.

The 3rd humble number is 3.

The 4th humble number is 4.

The 11th humble number is 12.

The 12th humble number is 14.

The 13th humble number is 15.

The 21st humble number is 28.

The 22nd humble number is 30.

The 23rd humble number is 32.

The 100th humble number is 450.

The 1000th humble number is 385875.

The 5842nd humble number is 2000000000.

题意:若一个数的所有素因子是2、3、5、7中的一个或多个,则这个数成为Humble数。求第n个Humble数是多少。

分析:若一个数是Humble数,则它的2、3、5、7倍仍然是Humble数。

设a[i]为第i个Humble数,则a
= min(2*a[b2], 3*a[b3], 5*a[b5], 7*a[b7]), b2、b3、b5、b7在不断更新。

最重要的一点:序数词的写法。

因为这个WA了很多次 (ノへ ̄、)

[code]#include<iostream>
#include <algorithm>
#include <cstdio>
#define N 6000
using namespace std;
typedef long long ll;
ll num
 = {0, 1};
inline ll MIN(ll a, ll b, ll c, ll d)
{
    ll t1 = a > b ? b : a;
    ll t2 = c > d ? d : c;
    return t1 > t2 ? t2 : t1;
}
void fun()
{
    ll a, b, c, d, t;
    a = b = c = d = 1;
    for (int i = 2; i <= 5900; i++)
    {
        t = MIN(2*num[a], 3*num[b], 5*num[c], 7*num[d]);
        num[i] = t;
        if (t == 2*num[a])
        {
            a++;
        }
        if(t == 3*num[b])
        {
            b++;
        }
        if (t == 5*num[c])
        {
            c++;
        }
        if (t == 7*num[d])
        {
            d++;
        }
    }
}

int main()
{
#ifndef  ONLINE_JUDGE
    freopen("1.txt", "r", stdin);
    //freopen("2.txt", "w", stdout);
#endif
    int n;
    fun();
    while(scanf("%d", &n), n)
    {

        printf("The %d", n);
        if (n%10 == 1 && n%100 != 11)
        {
            cout << "st";
        }
        else if (n%10 == 2 && n%100 != 12)
        {
            cout << "nd";
        }
        else if (n%10 == 3 && n%100 != 13)
        {
            cout << "rd";
        }
        else 
        {
            cout << "th";
        }
        printf(" humble number is ");
        cout << num
 << ".\n";
    }

    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: