您的位置:首页 > 其它

HDU 1160 FatMouse's Speed

2015-08-18 18:45 387 查看
HDU 1160 FatMouse’s Speed

Problem Description

FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.

Input

Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed.

Output

Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],…, m
then it must be the case that

W[m[1]] < W[m[2]] < … < W[m
]

and

S[m[1]] > S[m[2]] > … > S[m
]

In order for the answer to be correct, n should be as large as possible.

All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.

Sample Input

6008 1300

6000 2100

500 2000

1000 4000

1100 3000

6000 2000

8000 1400

6000 1200

2000 1900

Sample Output

4

4

5

9

7

首先建立一个结构体,里面包含老鼠的体重、速度、和输入时的顺序

然后按体重递增的顺序排序,之后再求这个序列中的最长递增子序列,最后输出路径(详见/article/3623462.html

[code]#include<iostream>
#include <cstdio>
#include <string.h>
#include <algorithm>
using namespace std;
struct mouse
{
    int weight;
    int speed;
    int id;
    friend bool operator < (const mouse &a, const mouse &b)
    {
        return a.weight < b.weight;
    }
}mice[1010];
int dp[1010];
int main()
{
#ifndef ONLINE_JUDGE
    freopen("1.txt", "r", stdin);
#endif
    int i = 1, j, n, M;
    int dp[1010], pre[1010], a[1010];
    while(~scanf("%d%d", &mice[i].weight, &mice[i].speed))
    {
        mice[i].id = i;
        dp[i] = 1;
        i++;
    }
    n = i - 1;
    memset(pre, 0, sizeof(pre));
    memset(a, 0, sizeof(a));
    sort(mice+1, mice+n+1);
    for (i = 1; i <= n; i++)
    {
        for (j = 1; j < i; j++)
        {
            if (mice[i].speed < mice[j].speed && mice[i].weight != mice[j].weight)
            {
                if (dp[i] < dp[j] + 1)
                {
                    dp[i] = dp[j] + 1;
                    pre[i] = j;
                }
            }
        }
    }
    M = 1;
    for (i = 1; i <= n; i++)
    {
        if (dp[M] < dp[i])
        {
            M = i;
        }
    }
    cout << dp[M] <<  endl;
    a[0] = M;
    i = 1;
    while(pre[M])
    {
        a[i] = pre[M];
        M = pre[M];
        i++;
    }
    for (i--; i >= 0; i--)
    {
        cout << mice[a[i]].id << endl;
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: