您的位置:首页 > 其它

Triangle LOVE 杭电HDU4324 【拓扑排序】

2015-08-18 10:09 330 查看
Problem Description

Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!

Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.

Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.



Input

The first line contains a single integer t (1 <= t <= 15), the number of test cases.

For each case, the first line contains one integer N (0 < N <= 2000).

In the next N lines contain the adjacency matrix A of the relationship (without spaces). Ai,j = 1 means i-th people loves j-th people, otherwise Ai,j = 0.

It is guaranteed that the given relationship is a tournament, that is, Ai,i= 0, Ai,j ≠ Aj,i(1<=i, j<=n,i≠j).



Output

For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.

Take the sample output for more details.



Sample Input

2
5
00100
10000
01001
11101
11000
5
01111
00000
01000
01100
01110




Sample Output

Case #1: Yes
Case #2: No



//TLE了N次,发现数组开小了

#include<stdio.h>
#include<string.h>
char map[2020][2020];
int indegree[2020];
int n;
bool Topo_Sort()
{
	for(int i=1;i<=n;++i)
	{
		int temp=-1;
		for(int j=0;j<n;++j)
		{
			if(indegree[j]==0)
			{
				temp=j;
				break;
			}
		}
		if(temp==-1) return 1;
		indegree[temp]=-1;
		for(int j=0;j<n;++j)
		{
			if(map[temp][j])
			{
				indegree[j]--;
			}
		}
	}
	return 0;
}
int main()
{
	int T;
	int i,j;
	int num=0;
	scanf("%d",&T);
	while(T--)
	{
		memset(indegree,0,sizeof(indegree));
		scanf("%d",&n);

		for(i=0;i<n;++i)
		{
			scanf("%s",&map[i]);
			for(j=0;j<n;++j)			
				if(map[i][j]=='1')				
					indegree[j]++;
		}
		
		printf("Case #%d: ",++num);
		if(Topo_Sort()) printf("Yes\n");
		else printf("No\n");
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: