您的位置:首页 > 其它

PAT 1037. Magic Coupon (25)

2015-08-17 13:02 225 查看


1037. Magic Coupon (25)

时间限制

100 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product
for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon
2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC,
NP <= 105, and it is guaranteed that all the numbers will not exceed 230.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.
Sample Input:
4
1 2 4 -1
4
7 6 -2 -3

Sample Output:
43


这道题的数也不大,我就直接用multiset了,把正的和正的相乘,负的和负的相乘即可。

代码如下

#include <iostream>
#include <string>
#include <iomanip>
#include <set>
#include <vector>
#include <cstring>
using namespace std;
int main(void)
{
int NC,NP;
cin>>NC;
multiset<int,greater<int> > coupons_plus;
multiset<int,greater<int> > product_plus;
multiset<int> coupons_minus;
multiset<int> product_minus;
while(NC--)
{
int temp;
cin>>temp;
if(temp>=0)
coupons_plus.insert(temp);
else
coupons_minus.insert(temp);
}
cin>>NP;
while(NP--)
{
int temp;
cin>>temp;
if(temp>=0)
product_plus.insert(temp);
else
product_minus.insert(temp);
}
multiset<int,greater<int> >::iterator it1;
multiset<int,greater<int> >::iterator it2;
int amount=0;
for(it1=coupons_plus.begin(),it2=product_plus.begin();it1!=coupons_plus.end()&&it2!=product_plus.end();it1++,it2++)
{
amount+=(*it1)*(*it2);
}
multiset<int>::iterator it3;
multiset<int>::iterator it4;
for(it3=coupons_minus.begin(),it4=product_minus.begin();it3!=coupons_minus.end()&&it4!=product_minus.end();it3++,it4++)
{
amount+=(*it3)*(*it4);
}
cout<<amount;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: