您的位置:首页 > 其它

【HDU4336】【Card Collector】【概率dp】

2015-08-17 09:57 288 查看


Card Collector

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3316 Accepted Submission(s): 1620

Special Judge


Problem Description

In your childhood, do you crazy for collecting the beautiful cards in the snacks? They said that, for example, if you collect all the 108 people in the famous novel Water Margin, you will win an amazing award.

As a smart boy, you notice that to win the award, you must buy much more snacks than it seems to be. To convince your friends not to waste money any more, you should find the expected number of snacks one should buy to collect a full suit of cards.



Input

The first line of each test case contains one integer N (1 <= N <= 20), indicating the number of different cards you need the collect. The second line contains N numbers p1, p2, ..., pN, (p1 + p2 + ... + pN <= 1), indicating the possibility of each card to
appear in a bag of snacks.

Note there is at most one card in a bag of snacks. And it is possible that there is nothing in the bag.



Output

Output one number for each test case, indicating the expected number of bags to buy to collect all the N different cards.

You will get accepted if the difference between your answer and the standard answer is no more that 10^-4.



Sample Input

1
0.1
2
0.1 0.4




Sample Output

10.000
10.500




Source

2012 Multi-University Training Contest 4



Recommend

zhoujiaqi2010 | We have carefully selected several similar problems for you: 4337 4331 4332 4333 4334

#include <iostream>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <list>
#include <map>
#include <set>
#include <string>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
using namespace std;
    
int n;
double p[25];
double dp[1<<20];
int main()
{
  
    while(scanf("%d",&n) != EOF)
	{
		memset(dp,0,sizeof(dp));
		for(int i=0;i<n;i++)
		{
			scanf("%lf",&p[i]);
		}
		int tot = (1 << n) - 1;
		dp[tot] = 0;
		for(int i=tot-1;i>=0;i--)
		{
			double p0 = 0;
			double p1 = 0;
			for(int j=0;j<n;j++)
			{
				if((i & (1 << j))) continue;
				p0 += p[j] * dp[i | (1 << j)];
				p1 += p[j];
			}
			double tmp = (1 + p0) / p1;
			dp[i] = tmp;

		}
		printf("%.5lf\n",dp[0]);

	}

    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: