您的位置:首页 > 其它

HDOJ-1671-字典树

2015-08-17 08:55 232 查看


Phone List

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 14623 Accepted Submission(s): 4932



Problem Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:

1. Emergency 911

2. Alice 97 625 999

3. Bob 91 12 54 26

In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number
is a sequence of at most ten digits.

Output

For each test case, output “YES” if the list is consistent, or “NO” otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346


Sample Output

NO
YES


大致题意:给定一些字符串,判断是否有两个字符串的前缀相同。前缀不包括自身,如样例 911 和 91125426 不算,而 12340和 123440则符合,很明显使用字典树解答。
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define MAX 10
struct node{
int key;
node *next[MAX];
node(){
key=0;
for(int i=0;i<MAX;i++)
next[i]=NULL;
}
};
node *root;
void tireInsert(char *str){
node*p=root,*q;
for(int i=0;str[i];i++){
int id=str[i]-'0';
if(!p->next[id])
p->next[id]=new node();
p=p->next[id];
}
p->key=1;
}
void dell(node*p)
{
if(p){
for(int i=0;i<MAX;i++)
if(p->next[i]){
dell(p->next[i]);
delete p->next[i];
}
}
}
int tireFind(char *str)
{
node *p=root;
int len=strlen(str);
for(int i=0;str[i];i++){
int id=str[i]-'0';
p=p->next[id];
if(!p)return 1;
if(p->key==1&&i<len-1)return 0;
}
return 1;
}
int main()
{
int N,T,i;
char str[10005][11];
scanf("%d",&T);
while(T--)
{
scanf("%d",&N);
root=new node();
for(i=0;i<N;i++){
scanf("%s",str[i]);
tireInsert(str[i]);
}
for(i=0;i<N;i++)
if(!tireFind(str[i]))
break;
printf(i<N?"NO\n":"YES\n");
dell(root);\\及时释放内存否则会超内存

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: