您的位置:首页 > 其它

UVa 1225 - Digit Counting

2015-08-16 17:37 169 查看
https://uva.onlinejudge.org/external/12/1225.pdf

Trung is bored with his mathematics homeworks. He takes a piece of chalk and starts writing a sequence of consecutive integers starting with 1 to N (1 < N < 10000) . After that, he counts the number of times each digit (0 to 9) appears in the sequence. For example, with N = 13 , the sequence is:

12345678910111213

In this sequence, 0 appears once, 1 appears 6 times, 2 appears 2 times, 3 appears 3 times, and each digit from 4 to 9 appears once. After playing for a while, Trung gets bored again. He now wants to write a program to do this for him. Your task is to help him with writing this program.

Input

The input file consists of several data sets. The first line of the input file contains the number of data sets which is a positive integer and is not bigger than 20. The following lines describe the data sets.

For each test case, there is one single line containing the number N .

Output

For each test case, write sequentially in one line the number of digit 0, 1,…9 separated by a space.

Sample Input

2

3

13

Sample Output

0 1 1 1 0 0 0 0 0 0

1 6 2 2 1 1 1 1 1 1

分析:

计算从1到N所有整数中出现0~9的次数并输出

#include <iostream>
#include <sstream>
#include <iomanip>
#include <vector>
#include <deque>
#include <list>
#include <set>
#include <map>
#include <stack>
#include <queue>
#include <bitset>
#include <string>
#include <numeric>
#include <algorithm>
#include <functional>
#include <iterator>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <cctype>
#include <complex>
#include <ctime>
#define INF 0x3f3f3f3f
#define eps 1e-6
#define p(x) printf("%d\n", x)
#define k(x) printf("Case %d: ", ++x)
#define mes(x, d) memset(x, d, sizeof(x))
#define s(x) scanf("%d", &x)

/*
int gcd(int a,int b)
{
return ! b ? a : gcd(b,a % b);
}

struct data
{
int val;
int pos;
int ranks;
}p[2005];

bool cmp1(const data &a,const data &b)
{
if(a.val == b.val)
return a.pos < b.pos;
return a.val < b.val;
}
bool cmp2(const data &a,const data &b)
{
return a.val > b.val;
}
bool cmp3(const data &a,const data &b)
{
return a.pos < b.pos;
}
*/

typedef long long LL;

const double pi = acos(-1.0);
const long long mod = 1e9 + 7;

using namespace std;

int f[10005][10];

int main()
{
//freopen("int.txt","r",stdin);
//freopen("out.txt","w",stdout);
memset(f,0,sizeof(f));
for(int i = 1;i < 10005;i++)
{
for(int j = 0;j < 10;j++)
f[i][j] = f[i - 1][j];
int left = i;
while(left)
{
f[i][left % 10]++;
left /= 10;
}
}
int T,N;
scanf("%d",&T);
while(T--)
{
scanf("%d",&N);
for(int i = 0;i < 9;i++)
printf("%d ",f
[i]);
printf("%d\n",f
[9]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: