您的位置:首页 > 其它

BestCoder Round #51 (div.2) & HDOJ5391 Zball in Tina Town(数论)

2015-08-16 09:45 323 查看


Zball in Tina Town

Time Limit: 3000/1500 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)

Total Submission(s): 305 Accepted Submission(s): 186



Problem Description

Tina Town is a friendly place. People there care about each other.

Tina has a ball called zball. Zball is magic. It grows larger every day. On the first day, it becomes 1 time
as large as its original size. On the second day,it will become 2 times
as large as the size on the first day. On the n-th day,it will become n times
as large as the size on the (n-1)-th day. Tina want to know its size on the (n-1)-th day modulo n.



Input

The first line of input contains an integer T,
representing the number of cases.

The following T lines,
each line contains an integer n,
according to the description.

T≤105,2≤n≤109



Output

For each test case, output an integer representing the answer.



Sample Input

2
3
10




Sample Output

2
0




题目即求(n - 1)! % n,威尔逊定理的应用,注意数据4就好了。

AC代码:

#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"
#include "cmath"
using namespace std;
int n;
bool judge(int n)
{
	if(n <= 2) return n == 2;
	if(n % 2 == 0) return false;
	int x = sqrt(n);
	for(int i = 3; i <= x; i += 2)
		if(n % i == 0) return false;
	return true;
}
int main(int argc, char const *argv[])
{
	int t;
	scanf("%d", &t);
	while(t--) {
		scanf("%d", &n);
		if(n == 4) printf("2\n");
		else if(judge(n)) printf("%d\n", n - 1);
		else printf("0\n");
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: