您的位置:首页 > 其它

poj-2406-Power Strings (kmp)

2015-08-13 13:04 405 查看
Power Strings

Time Limit : 6000/3000ms (Java/Other) Memory Limit : 131072/65536K (Java/Other)

Total Submission(s) : 157 Accepted Submission(s) : 59

Problem Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the
empty string) and a^(n+1) = a*(a^n).



Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.



Output

For each s you should print the largest n such that s = a^n for some string a.



Sample Input

abcd

aaaa

ababab

.



Sample Output

1

4

3

//poj-2406-Power Strings (字符串匹配KMP)
//题目大意:给你一列字符串;求这列字符串的循环节的循环次数;如,abcd各个字符都不同;它本身是一个循环节,所以答案是一;
//又如:ababab 的循环节是ab;循环三次;所以答案是三;
//解题思路:
//本题可利用kmp函数中getp函数(字符串匹配中对子串预处理的函数)的性质来解决;假设有一字符串str,长度为len;定义一个p[]数组;
//str经过getp函数处理后,如果 len%(len-p[len])==0,那么str是一个周期串;其循环节的长度是len-p[len];循环的次数是len/(len-p[len]).
#include<stdio.h>
#include<string.h>
#define K 1000100
char str1[K];
int count,len1,len2,p[K];
void getp(){
	int i=0,j=-1;
	p[i]=j;
	while(i<len1){
		if(j==-1||str1[i]==str1[j]){
			i++,j++;
			p[i]=j;}
		else
		j=p[j];
	}	
}

int main()
{ 
	int i,x;
	while(scanf("%s",str1)){
		if(strcmp(str1,".")==0)
		 break;
		 len1=strlen(str1);
		getp();
		x=len1%(len1-p[len1]);
		if(x==0)
		 printf("%d\n",len1/(len1-p[len1]));
		else
		 printf("1\n");
		}	
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: