您的位置:首页 > 大数据 > 人工智能

2015 Multi-University Training Contest 7 hdu 5373 The shortest problem

2015-08-11 20:30 465 查看

The shortest problem

Time Limit: 3000/1500 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 346 Accepted Submission(s): 167


[align=left]Problem Description[/align]
In this problem, we should solve an interesting game. At first, we have an integer n, then we begin to make some funny change. We sum up every digit of the n, then insert it to the tail of the number n, then let the new number be the interesting number n. repeat it for t times. When n=123 and t=3 then we can get 123->1236->123612->12361215.

[align=left]Input[/align]
Multiple input.
We have two integer n (0<=n<=104 ) , t(0<=t<=105) in each row.
When n==-1 and t==-1 mean the end of input.

[align=left]Output[/align]
For each input , if the final number are divisible by 11, output “Yes”, else output ”No”. without quote.

[align=left]Sample Input[/align]

35 2

35 1

-1 -1

[align=left]Sample Output[/align]

Case #1: Yes

Case #2: No

[align=left]Source[/align]
2015 Multi-University Training Contest 7 1005

解题:由于能被11整除的数的特点是奇数位与偶数位的和的绝对值可以被11整除,所以,搞一下就可以了

#include <bits/stdc++.h>
using namespace std;
int cur = 0,n,m,d[2];
int solve(int x) {
int a[2] = {0};
cur = 0;
while(x) {
a[cur^1] += x%10;
x /= 10;
cur ^= 1;
}
if(cur&1) swap(d[0],d[1]);
d[0] += a[0];
d[1] += a[1];
return d[0] + d[1];
}
int main() {
int cs = 1;
while(scanf("%d%d",&n,&m),(~n) && (~m)) {
d[0] = d[1] = 0;
for(int i = 0; i <= m; ++i) n = solve(n);
printf("Case #%d: %s\n",cs++,abs(d[0]-d[1])%11?"No":"Yes");
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: