您的位置:首页 > 产品设计 > UI/UE

HDU 1005 Number Sequence

2015-08-11 13:09 302 查看
A - Number Sequence
Time Limit:5000MS Memory Limit:32768KB 64bit IO Format:%I64d
& %I64u
SubmitStatus

Description

Given two sequences of numbers : a[1], a[2], ...... , a
, and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M].
If there are more than one K exist, output the smallest one.

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate
a[1], a[2], ...... , a
. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1


Sample Output

6
-1


KMP基础问题。在一个数列中匹配另一个数列。问k等于几的时候,使得移位k后两个数列匹配上。

#include <stdio.h>
#define N 1000005
int a
,b
,nxt
;
int n,m;
void getnext(){
int j=0, k=-1;
nxt[0] = -1;
while(j<m){
if (k==-1 || b[j]==b[k]){
nxt[++j] = ++k;
}
else{
k = nxt[k];
}
}
}
int kmp(){
getnext();
int j=0, k=0;
while(k<m && j<n){
if (k==-1 || b[k]==a[j]){
++k;++j;
}
else{
k = nxt[k];
}
}
if(k==m) return j-m+1;
return -1;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
for(int i=0;i<n;i++)
scanf("%d",&a[i]);
for(int i=0;i<m;i++)
scanf("%d",&b[i]);
printf("%d\n",kmp());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: