您的位置:首页 > 产品设计 > UI/UE

hdoj1159 Common Subsequence

2015-08-10 20:46 561 查看

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 28533 Accepted Submission(s): 12754

Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing
sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of
the maximum-length common subsequence of X and Y.

The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard
output the length of the maximum-length common subsequence from the beginning of a separate line.



Sample Input
abcfbc abfcab
programming contest 
abcd mnp




Sample Output
4
2
0



这道题用暴力解,不用想一定超时!



1、字符相同,则指向左上,并加1

2、字符不同,则指向左边或者上边较大的那个

#include<stdio.h>

#include<string.h>

#define max(a,b) (a>b?a:b)

char ch1[1005],ch2[1005];//两个进行比较的字符串数组

int dp[1005][1005];

int len1,len2;

int main()

{

while(scanf("%s%s",ch1,ch2)!=EOF)

{

memset(dp,0,sizeof(dp));

int len1=strlen(ch1);

int len2=strlen(ch2);

int i,j;

for(i=1;i<=len1;i++)

for(j=1;j<=len2;j++)

{

if(ch1[i-1]==ch2[j-1])//这里用动态规划的思想,对两字符串进行循环的比对

dp[i][j]=dp[i-1][j-1]+1;

else

dp[i][j]=max(dp[i][j-1],dp[i-1][j]);

}

printf("%d\n",dp[len1][len2]);//直到字符串数组比对完毕!

}

return 0;

}

原题目:hdoj1159 Common Subsequence
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: