您的位置:首页 > 其它

Courses

2015-08-10 17:52 211 查看
Courses Time Limit:10000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u

Submit Status Practice HDU 1083

Description

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

. every student in the committee represents a different course (a student can represent a course if he/she visits that course)

. each course has a representative in the committee

Your
program should read sets of data from a text file. The first line of
the input file contains the number of the data sets. Each data set is
presented in the following format:

P N
Count1 Student1 1 Student1 2 ... Student1 Count1
Count2 Student2 1 Student2 2 ... Student2 Count2
......

CountP StudentP 1 StudentP 2 ... StudentP CountP

The
first line in each data set contains two positive integers separated by
one blank: P (1 <= P <= 100) - the number of courses and N (1
<= N <= 300) - the number of students. The next P lines describe
in sequence of the courses . from course 1 to course P, each line
describing a course. The description of course i is a line that starts
with an integer Count i (0 <= Count i <= N) representing the
number of students visiting course i. Next, after a blank, you'll find
the Count i students, visiting the course, each two consecutive
separated by one blank. Students are numbered with the positive integers
from 1 to N.

There are no blank lines between consecutive sets of data. Input data are correct.

The result of the program is on the standard output. For
each input data set the program prints on a single line "YES" if it is
possible to form a committee and "NO" otherwise. There should not be any
leading blanks at the start of the line.

An example of program input and output:

Sample Input

2

3 3

3 1 2 3

2 1 2

1 1

3 3

2 1 3

2 1 3

1 1

Sample Output

YES

NO

题意:学生可以自由选择上什么课,上多少种课,每个学生可以代表一门课,问最后是否有的课没有找到学生可以代表。当然一个学生只能代表一门课。
明显匈牙利算法

#include<iostream>
#include<cstring>
#include<cstdio>

using namespace std;

#define N 330

int p, n, vis
, used
, maps

;

void init()
{
memset(vis, 0, sizeof(vis));
memset(used, 0, sizeof(used));
memset(maps, 0, sizeof(maps));
}

int found(int u)
{
for(int i = 1; i <= n; i++)
{
if(maps[u][i] && !vis[i])  // 这个学生愿意上这么课,
{
vis[i] = 1;
if(!used[i] || found(used[i]))   // 并且这个学生没有代表其他课,或者它代表的课有其他人代表,那么这个人就可以代表这门课
{
used[i] = u;
return true;
}
}
}
return false;
}

int main()
{
int t, q, x;

scanf("%d", &t);

while(t--)
{
init();

scanf("%d%d", &p, &n);

for(int i = 1; i <= p; i++)
{
scanf("%d", &q);
while(q--)
{
scanf("%d", &x);
//used[x] = i;
maps[i][x] = 1;   // i 这门课被x学生代表
}
}

int flag = 0;

for(int i = 1; i <= p; i++)
{
memset(vis, 0, sizeof(vis));

if(!found(i))  // 如果这门课找不到学生代表,flag=1,break;只要有一门课找不到别人代表,就printf  “NO
{
flag = 1;
break;
}
}
if(flag)
printf("NO\n");
else
puts("YES");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: