您的位置:首页 > 其它

hdu 1028 Ignatius and the Princess III +hdu 1085 Holding Bin-Laden Captive!(母函数)

2015-08-10 16:05 459 查看

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 15675 Accepted Submission(s): 11054Problem Description"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says."The second problem is, given an positive integer N, we define an equation like this:N=a[1]+a[2]+a[3]+...+a[m];a[i]>0,1<=m<=N;My question is how many different equations you can find for a given N.For example, assume N is 4, we can find:4 = 4;4 = 3 + 1;4 = 2 + 2;4 = 2 + 1 + 1;4 = 1 + 1 + 1 + 1;so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"InputThe input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.OutputFor each test case, you have to output a line contains an integer P which indicate the different equations you have found.Sample Input
4
10
20
Sample Output
5
42
627

题目大意:整数拆分。问对于整数n,有多少种拆分方式。
思路:普通型母函数。该问题可以表示成(1+x+x^2+x^3+...+x^n)(1+x^2+x^4+...x^n)..(1+x^n)。
多项式里面的每一项表示用哪个整数来凑成n。

#include<stdio.h>
#include<string.h>
int main()
{
int c1[130],c2[130];
int i,j,k,n;
while(~(scanf("%d",&n)))
{

for(i=0;i<=130;i++)
{
c1[i]=1;
c2[i]=0;
}
for(i=2;i<=n;i++)
{
for(j=0;j<=n;j++)
{
for(k=0;k+j<=n;k+=i)
{
c2[k+j]+=c1[j];
}
}
for(j=0;j<=n;j++)
{
c1[j]=c2[j];
c2[j]=0;
}
}
printf("%d\n",c1
);
}
}

Holding Bin-Laden Captive!

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 17463 Accepted Submission(s): 7827Problem DescriptionWe all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China!“Oh, God! How terrible! ”Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up!Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?“Given some Chinese Coins (硬币) (three kinds-- 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!InputInput contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed.OutputOutput the minimum positive value that one cannot pay with given coins, one line for one case.Sample Input[code]1 1 30 0 0
Sample Output
4
Authorlcy题目大意:有面值为1、2、5的硬币(数量有限),问硬币不能组成的最小面值。思路:普通型母函数。注意数量有限,上一题是数量无限。
#include<stdio.h>#include<string.h>int main(){int i,j,k,num[8];int c1[8005],c2[8005],coin[4]={0,1,2,5};while(scanf("%d%d%d",&num[1],&num[2],&num[3])!=EOF){if(num[1]==0&&num[2]==0&&num[3]==0)break;memset(c1,0,sizeof(c1));memset(c2,0,sizeof(c2));int sum=num[1]+2*num[2]+5*num[3];for(i=0;i<=num[1];i++)c1[i]=1;for(i=2;i<=3;i++){for(j=0;j<=sum;j++){for(k=0;k*coin[i]+j<=sum&&k<=num[i];k++)c2[k*coin[i]+j]+=c1[j];}for(j=0;j<=sum;j++){c1[j]=c2[j];c2[j]=0;}}for(i=1;i<=8005;i++){if(!c1[i]){printf("%d\n",i);break;}}}}

                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: