您的位置:首页 > 其它

BestCoder Round #50 (div.2) 1001

2015-08-09 09:26 309 查看

Distribution money

Accepts: 713

Submissions: 1881

Time Limit: 2000/1000 MS (Java/Others)

Memory Limit: 65536/65536 K (Java/Others)

Problem Description
AFA want to distribution her money to somebody.She divide her money into n same parts.One who want to get the money can get more than one part.But if one man's money is more than the sum of all others'.He shoule
be punished.Each one who get a part of money would write down his ID on that part.
Input
There are multiply cases. For each case,there is a single integer n(1<=n<=1000) in first line. In second line,there are n integer a1,a2...an(0<=ai<10000)ai is the the ith man's ID.
Output
Output ID of the man who should be punished. If nobody should be punished,output -1.
Sample Input
31 1 242 1 4 3
Sample Output
1-1

签到题,当前序号下所占的份数大于0.5,则输出该序号,都没有则输出-1

默默地吐槽杭电不支持#include<bits/stdc++.h>

//#include<bits/stdc++.h>
#include<cstdio>
#include<iostream>
using namespace std;

int n;

struct div
{
    double b;
}ans[10100];
int main()
{
    //freopen("in.txt","r",stdin);
    while(~scanf("%d",&n))
    {
        int x,count=-1;
        for(int i=0;i<n;i++)
            ans[i].b=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&x);
            ans[x].b+=1.0/n;
            if(ans[x].b>(1.0/2))
                count=x;
        }
        printf("%d\n",count);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: