您的位置:首页 > 其它

POJ 3617.Best Cow Line

2015-08-17 14:19 99 查看
Best Cow Line

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 13735Accepted: 3934
Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase
ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's
finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N

* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the
ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input
6
A
C
D
B
C
B

Sample Output
ABCBCD

贪心就行了

这个题,我好委屈,但我不说。。。

#include<cstdio>
#include<cstring>

int n;
char a[2010],c[2010];

int main()
{
    //freopen("in.txt","r",stdin);
    scanf("%d",&n);
    for(int i=0;i<n;i++)
    {
        scanf("%*c%c",&a[i]);
    }
    int x=0,y=n-1;
    for(int i=0;i<n;i++)
    {
        if(a[x]>a[y])
            c[i]=a[y--];
        else if(a[x]<a[y])
            c[i]=a[x++];
        else
        {
            int fx=x,fy=y;
            while(a[fx]==a[fy]&&fx<=fy)
                fx++,fy--;
            if(a[fx]<a[fy])
                c[i]=a[x++];
            else
                c[i]=a[y--];
        }
    }
    for(int i=0;i<n;i++)
    {
        printf("%c",c[i]);
        if(i%80==79)
            printf("\n");
    }
    if(n%80)  printf("\n");
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: