您的位置:首页 > 大数据 > 人工智能

2015 Multi-University Training Contest 6 Cake

2015-08-07 20:01 429 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5355

Problem Description

There are m soda and today is their birthday. The 1-st soda has prepared n cakes with size 1,2,…,n. Now 1-st soda wants to divide the cakes into m parts so that the total size of each part is equal.

Note that you cannot divide a whole cake into small pieces that is each cake must be complete in the m parts. Each cake must belong to exact one of m parts.

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first contains two integers n and m (1≤n≤105,2≤m≤10), the number of cakes and the number of soda.

It is guaranteed that the total number of soda in the input doesn’t exceed 1000000. The number of test cases in the input doesn’t exceed 1000.

Output

For each test case, output “YES” (without the quotes) if it is possible, otherwise output “NO” in the first line.

If it is possible, then output m lines denoting the m parts. The first number si of i-th line is the number of cakes in i-th part. Then si numbers follow denoting the size of cakes in i-th part. If there are multiple solutions, print any of them.

Sample Input

4

1 2

5 3

5 2

9 3

Sample Output

NO

YES

1 5

2 1 4

2 2 3

NO

YES

3 1 5 9

3 2 6 7

3 3 4 8

题意理解:给你n个尺寸大小分别为1,2,3,…,n的蛋糕,要求你分成m份,要求每份中所有蛋糕的大小之和均相同,如果有解,输出“YES”,并给出每份的蛋糕数及其尺寸大小,否则输出“NO”



开始的时候想的是简单的暴力(肯定没有那么简单),没想到竟然过了,但是之后的spj之后就出现错误了,所以原来的思路还是出现了问题的.

原来的代码:

[code]#include<iostream>
#include<cstdio>
#include<map>
#include<set>
#include<vector>
#include<queue>
#include<cmath>
#include<string>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;

#define eps 1e-8
#define INF 0x3f3f3f3f
#define LL long long
#define Max(a,b) ((a)>(b)?(a):(b))
#define Min(a,b) ((a)<(b)?(a):(b))
typedef pair<int , int> P;
#define N 100005

bool number
;//标记蛋糕是否已经取掉
int ans
;
int n,m;

void Find(int x)//查找平均大小为x的分配方案
{
    for(int i = 0; i < m; i++)
    {
        int temp = x,ncount = 0;
        for(int j = n;j > 0 && temp != 0 ;j--)
        {
            if((temp - j >= 0) && number[j] == 0)//每次取能取的最大蛋糕
            {
                ans[ncount++] = j;
                number[j] = 1;
                temp -= j;
            }
        }
        printf("%d ",ncount);
        for(int j = 0; j < ncount; j++)
            printf("%d ",ans[j]);
        if(temp>0) cout<<"temp="<<temp<<",该组测试数据不为满足要求...";
        printf("\n");
    }
}

int main()
{
    int Case;
    scanf("%d",&Case);
    while(Case--)
    {
        scanf("%d%d",&n,&m);
        int sum = ((n + 1) * n)>>1;///计算前n个蛋糕的总质量
        memset(number,0,sizeof(number));///初始化标记方阵

        if(sum % m == 0 && (2 * m - 1) <= n ) ///如果是总质量取余不为0  &&   分不到一个
        {
            printf("YES\n");
            Find(sum/m);
        }
        else
            printf("NO\n");
    }
    return 0;
}


之后借鉴网上的代码,和官网给出的思路很想,但是没有使用递归,感觉这道题的难点有两个,一个是判断什么情况下是直接不行的,但是自己感觉好像不能理解为什么两个条件和结果是充分条件,(现在感觉只是必要条件,有点不懂。。。);另一个是需要分割为两部分,第一部分拼凑,第二部分直接分开输出就好了。

关键是思路。。。

借鉴网址:/article/2498886.html

[code]#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<queue>
#include<math.h>
#include<vector>
#include<map>
#include<set>
#include<cmath>
#include<string>
#include<algorithm>
#include<iostream>
#define exp 1e-10
#define ll __int64
using namespace std;

int solve()
{
    int  n,m;
    int i,j,k,c,s,d,r,w[32];
    set<int> v;

    set<int>::iterator it;
    scanf("%d%d",&n,&m);
    if(( (n+1)*n/2)%m || m*2-1>n  )
        return puts("NO");

    c=(n-  (m*2-1) )%(m*2)+m*2-1,///算出前一部分有多少个数
    s=c*(c+1)/(m*2),   ///前面每两个数的和为s
    d=(n-c)/(m*2);     ///后面每组有多少个

    puts("YES");
    for(i=1; i<=c; i++)
        v.insert(i);
    for( j=0,k=c+1;  j<m;  j++,putchar('\n') )
    {
        c=r=0;
        while(r<s)
        {
            it=v.upper_bound(s-r);///查找函数,返回查找比查找值大的第一个位置指针(iterator)[使用方法]
            --it;
            w[c]=*it;///获得该位置指针所指向的数据
            r=r+w[c++];
            v.erase(it);
        }
        printf("%d*",c+d*2);  ///输出个数

        for(i=0;i<c;i++)   ///前半部分
            printf(" %d",w[i]);

        for(i=0;i<d;i++)///直接输出后半部分
            printf(" %d %d",k++,n--);
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
        solve();
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: