您的位置:首页 > 其它

1073. Scientific Notation (20)

2015-08-07 12:47 155 查看
题目如下:

Scientific notation is the way that scientists easily handle very large numbers or very small numbers. The notation matches the regular expression [+-][1-9]"."[0-9]+E[+-][0-9]+ which means that the integer portion has exactly one digit, there is at least one
digit in the fractional portion, and the number and its exponent's signs are always provided even when they are positive.

Now given a real number A in scientific notation, you are supposed to print A in the conventional notation while keeping all the significant figures.

Input Specification:

Each input file contains one test case. For each case, there is one line containing the real number A in scientific notation. The number is no more than 9999 bytes in length and the exponent's absolute value is no more than 9999.

Output Specification:

For each test case, print in one line the input number A in the conventional notation, with all the significant figures kept, including trailing zeros,
Sample Input 1:
+1.23400E-03

Sample Output 1:
0.00123400

Sample Input 2:
-1.2E+10

Sample Output 2:
-12000000000


题目要求对给定的科学计数法进行解析,并且输出传统计数法表示的数字,要求正数不带正号,小数保留原来的后缀0个数。

这个题的关键是结合string的find、substr方法查找和截取,使用stringstream来转换字符串到数字。

此类问题最主要的是抓住分类讨论的要点,处理尽可能少的情况。

最初我用遍历的方法找到各个部分的位置,发现比较繁琐,后来参考了xtzmm1215的解法,发现使用find和substr会方便许多。

下面是xtzmm1215的代码,我补充了一些注释,使之易读:

#include <cstdio>
#include <iostream>
#include <string>
#include <sstream>
using namespace std;

int main(){
	string s, ans = "";
	getline(cin, s);
	if (s[0] == '-')
		ans += s[0]; // 负数前面才加负号
	int indexE = s.find("E");
	string num = s.substr(1, indexE-1);
	char x = s[indexE + 1];
	string exp = s.substr(indexE+2, s.size() - indexE - 2);
	stringstream ss;
	ss << exp;
	int e;
	ss >> e;
	if (e == 0){ // 指数为0直接输出
		cout << ans << num << endl;
		return 0;
	}
	if (x == '+'){ // 正指数的情况
		if (e < num.size() - 2){ // num.size()-2是减去小数点和1以后的部分,如果指数达不到,需要在合适的地方加小数点。
			ans = ans + num[0] + num.substr(2, e) + "." + num.substr(e + 2, num.size() - e - 2);
		}
		else{ // num.size()-2如果和指数相当,则需要补充0来扩大数字。
			ans = ans + num[0] + num.substr(2, num.size()-2);
			for (int i = 0; i < e - num.size() + 2; i++)
				ans += "0";
		}
	}
	if (x == '-'){ // 负指数的情况,需要前补0,0.算作一次指数,因此指数减到1就应该停止前补0.
		ans = ans + "0.";
		while (e-- != 1)
			ans += "0";
		ans = ans + num[0] + num.substr(2, num.size()-2);
	}
	cout << ans << endl;
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: