您的位置:首页 > 大数据 > 人工智能

HDU 5360 Hiking(优先队列)2015 Multi-University Training Contest 6

2015-08-06 18:37 459 查看

Hiking

Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 97 Accepted Submission(s): 56

Special Judge


Problem Description
There are n


soda conveniently labeled by 1,2,…,n

.
beta, their best friends, wants to invite some soda to go hiking. The
i

-th
soda will go hiking if the total number of soda that go hiking except him is no less than
l

i




and no larger than r

i



.
beta will follow the rules below to invite soda one by one:

1. he selects a soda not invited before;

2. he tells soda the number of soda who agree to go hiking by now;

3. soda will agree or disagree according to the number he hears.

Note: beta will always tell the truth and soda will agree if and only if the number he hears is no less than
l

i




and no larger than r

i



,
otherwise he will disagree. Once soda agrees to go hiking he will not regret even if the final total number fails to meet some soda's will.

Help beta design an invitation order that the number of soda who agree to go hiking is maximum.



Input
There are multiple test cases. The first line of input contains an integer
T

,
indicating the number of test cases. For each test case:

The first contains an integer n


(1≤n≤10

5

)

,
the number of soda. The second line constains n


integers l

1

,l

2

,…,l

n



.
The third line constains n


integers r

1

,r

2

,…,r

n



.
(0≤l

i

≤r

i

≤n)


It is guaranteed that the total number of soda in the input doesn't exceed 1000000. The number of test cases in the input doesn't exceed 600.



Output
For each test case, output the maximum number of soda. Then in the second line output a permutation of
1,2,…,n


denoting the invitation order. If there are multiple solutions, print any of them.



Sample Input
4
8
4 1 3 2 2 1 0 3
5 3 6 4 2 1 7 6
8
3 3 2 0 5 0 3 6
4 5 2 7 7 6 7 6
8
2 2 3 3 3 0 0 2
7 4 3 6 3 2 2 5
8
5 6 5 3 3 1 2 4
6 7 7 6 5 4 3 5




Sample Output
7
1 7 6 5 2 4 3 8
8
4 6 3 1 2 5 8 7
7
3 6 7 1 5 2 8 4
0
1 2 3 4 5 6 7 8




Source
2015 Multi-University Training Contest 6

#include<stdio.h>
#include<queue>
#include<algorithm>
#include<string.h>
using namespace std;
const int N = 100005;
struct nnn
{
    int l,r,id;
}node
;
struct NNNN
{
    int r,id;
    friend bool operator<(NNNN aa,NNNN bb){
        return aa.r>bb.r;
    }
};

priority_queue<NNNN>q;
int id
;
bool vist
;

bool cmp1(nnn aa, nnn bb){ return aa.l<bb.l;}
int main()
{
    int T,n,ans;
    NNNN now;
    scanf("%d",&T);
    while(T--){
        scanf("%d",&n);
        ans=0;

        for(int i=0; i<n; i++){
            scanf("%d",&node[i].l);
            node[i].id=i+1;
        }
        for(int i=0; i<n; i++)
            scanf("%d",&node[i].r);
        sort(node,node+n,cmp1);
        memset(vist,0,sizeof(vist));
        int i=0;
        while(i<n){
            bool ff=0;
            while(i<n&&ans>=node[i].l&&ans<=node[i].r){
                now.r=node[i].r; now.id=node[i].id;
                q.push(now);
                //printf("in = %d\n",now.id);
                i++; ff=1;
            }
            if(ff)i--;
            while(!q.empty()){
                now=q.top(); q.pop();
                if(now.r<ans)continue;
                //printf("out = %d\n",now.id);
                ans++; id[ans]=now.id;vist[now.id]=1;
                if(node[i+1].l<=ans)
                    break;
            }
            i++;
        }
        while(!q.empty()) {
            now=q.top(); q.pop();
            if(now.r<ans)continue;
            //printf("out = %d\n",now.id);
            ans++; id[ans]=now.id; vist[now.id]=1;
        }
        
        bool fff=0;
        printf("%d\n",ans);
        for( i=1; i<=ans; i++) if(i>1) printf(" %d",id[i]); else if(i==1) printf("%d",id[i]);
        if(ans)fff=1;
        for( i=1; i<=n; i++) if(vist[i]==0&&fff) printf(" %d",i); else if(vist[i]==0) printf("%d",i),fff=1;
        printf("\n");
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: