您的位置:首页 > 其它

HDU 2680 Choose the best route

2015-08-06 15:31 399 查看
Description

One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.


Input

There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.


Output

The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.


Sample Input

5 8 5
1 2 2
1 5 3
1 3 4
2 4 7
2 5 6
2 3 5
3 5 1
4 5 1
2
2 3
4 3 4
1 2 3
1 3 4
2 3 2
1
1


Sample Output

1
-1


#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
using namespace std;

const int INF=0x7f7f7f7f;
const int maxn=1005;
int dis[maxn];
bool vis[maxn];
int Map[maxn][maxn];
int n,m,s;

void init()
{
memset(vis,false,sizeof(vis));
memset(dis,INF,sizeof(vis));
memset(Map,INF,sizeof(Map));
}

void dij(int s)
{
for(int i=1; i<=n; i++)
dis[i] = Map[s][i];
vis[s] = 1;
dis[s] = 0;
for(int i=1; i<n; i++)
{
int minn = INF, mark;
for(int j = 1; j <= n; j++)
if(!vis[j] && dis[j] < minn)
{
minn=dis[j];
mark=j;
}
if(minn == INF)
break;
vis[mark] = true;
for(int j=1; j<=n; j++)
if(!vis[j] && dis[mark] + Map[mark][j] < dis[j])
dis[j] = dis[mark] + Map[mark][j];
}
}

int main()
{
while(~scanf("%d%d%d",&n,&m,&s))
{
init();
while(m--)
{
int p,q,t;
scanf("%d%d%d",&p,&q,&t);
if(Map[q][p]>t)
{
Map[q][p]=t;
}
}
int tt,e,ans=INF;
dij(s);
scanf("%d",&tt);
while(tt--)
{
scanf("%d",&e);
ans=min(ans,dis[e]);
}
if(ans!=INF)
printf("%d\n",ans);
else
printf("-1\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: