您的位置:首页 > 其它

hdu -1049 Climbing Worm

2015-08-05 17:33 399 查看

Climbing Worm

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 14400    Accepted Submission(s): 9719


[align=left]Problem Description[/align]
An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and
resting then repeats. How long before the worm climbs out of the well? We'll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we'll assume the worm makes it out.

 

[align=left]Input[/align]
There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end
of output.

 

[align=left]Output[/align]
Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.

 

[align=left]Sample Input[/align]

10 2 1
20 3 1
0 0 0

 

[align=left]Sample Output[/align]

17
19

 

[align=left]Source[/align]
East Central North America 2002

 

//非常水的一道题,题意就是洞总长n英尺,每一分钟爬u英尺,然后休息一分钟,掉落d英尺;求出洞所用时间?
代码如下:
#include <iostream>

#include <cstdio>

#include <cmath>

#include <cstring>

using namespace std;

int main()

{

    int n,u,d;

    while(scanf("%d%d%d",&n,&u,&d)!=EOF,n)

    {

        int c=0;

        while(n>0)//判断爬虫是否出界

        {

            if(n>0)//计算所用时间

            {

               n-=u;

               c++;

               if(n==0)

                break;

            }

           // cout<<n<<endl;//测试数据

            if(n>0)

            {

                n+=d;

                c++;

            }

            //cout<<n<<endl;

        }

        cout<<c<<endl;//输出结果

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM 杭电oj 算法