您的位置:首页 > 其它

HDOJ1342lotto(DFS)

2015-08-05 16:51 351 查看

Lotto

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 1755    Accepted Submission(s): 860


[align=left]Problem Description[/align]
In a Lotto I have ever played, one has to select 6 numbers from the set {1,2,...,49}. A popular strategy to play Lotto - although it doesn't increase your chance of winning - is to select a subset S containing k (k>6) of these 49
numbers, and then play several games with choosing numbers only from S. For example, for k=8 and S = {1,2,3,5,8,13,21,34} there are 28 possible games: [1,2,3,5,8,13], [1,2,3,5,8,21], [1,2,3,5,8,34], [1,2,3,5,13,21], ... [3,5,8,13,21,34].

Your job is to write a program that reads in the number k and the set S and then prints all possible games choosing numbers only from S.

 

 

[align=left]Input[/align]
The input file will contain one or more test cases. Each test case consists of one line containing several integers separated from each other by spaces. The first integer on the line will be the number k (6 < k < 13). Then k integers,
specifying the set S, will follow in ascending order. Input will be terminated by a value of zero (0) for k.

 

 

[align=left]Output[/align]
For each test case, print all possible games, each game on one line. The numbers of each game have to be sorted in ascending order and separated from each other by exactly one space. The games themselves have to be sorted lexicographically,
that means sorted by the lowest number first, then by the second lowest and so on, as demonstrated in the sample output below. The test cases have to be separated from each other by exactly one blank line. Do not put a blank line after the last test case.

 

 

[align=left]Sample Input[/align]

7 1 2 3 4 5 6 7
8 1 2 3 5 8 13 21 34
0

 

 

[align=left]Sample Output[/align]

1 2 3 4 5 6
1 2 3 4 5 7
1 2 3 4 6 7
1 2 3 5 6 7
1 2 4 5 6 7
1 3 4 5 6 7
2 3 4 5 6 7

1 2 3 5 8 13
1 2 3 5 8 21
1 2 3 5 8 34
1 2 3 5 13 21
1 2 3 5 13 34
1 2 3 5 21 34
1 2 3 8 13 21
1 2 3 8 13 34
1 2 3 8 21 34
1 2 3 13 21 34
1 2 5 8 13 21
1 2 5 8 13 34
1 2 5 8 21 34
1 2 5 13 21 34
1 2 8 13 21 34
1 3 5 8 13 21
1 3 5 8 13 34
1 3 5 8 21 34
1 3 5 13 21 34
1 3 8 13 21 34
1 5 8 13 21 34
2 3 5 8 13 21
2 3 5 8 13 34
2 3 5 8 21 34
2 3 5 13 21 34
2 3 8 13 21 34
2 5 8 13 21 34
3 5 8 13 21 34

 

/*全排列,加DFS*/

/*题意大概是对于所给的数,从小到大输出6个数*/

/*大致思想是,对于全排列的结果,选择性的输出,输出递增的排列*/

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[101],s[101];
int map[1010];
int n,count;
void dfs(int x)
{
if (x==6)
{
int i;
for (i=0;i<5;i++)
printf ("%d ",s[i]);
printf ("%d\n",s[5]);
return ;
}
for (int i=0;i<n;i++)
{
if (!map[i]&&a[i]>s[x-1])//搜索时,选择出比前面已经排列过得数要大,这样可以减少搜索的次数
{
map[i]=1;
s[x]=a[i];
dfs(x+1);
map[i]=0;
}
}
}
int main()
{
memset(map,0,sizeof(map));
while (scanf ("%d",&n),n)
{
for (int i=0;i<n;i++)
{
scanf ("%d",&a[i]);
}
sort(a,a+n);
dfs(0);
printf ("\n");
}
return 0;
}


 

 

 

 

 

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: