您的位置:首页 > 其它

Courses

2015-08-05 16:51 176 查看
[align=left]Problem Description[/align]
Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

. every student in the committee represents a different course (a student can represent a course if he/she visits that course)

. each course has a representative in the committee

Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format:

P N

Count1 Student1 1 Student1 2 ... Student1 Count1

Count2 Student2 1 Student2 2 ... Student2 Count2

......

CountP StudentP 1 StudentP 2 ... StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P,
each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you'll find the Count i students, visiting the course,
each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.

There are no blank lines between consecutive sets of data. Input data are correct.

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

An example of program input and output:
 

[align=left]Sample Input[/align]

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

 

[align=left]Sample Output[/align]

YES
NO

题解:课程与学生匹配,没门课程必须匹配一个学生,也就是最大匹配数等于课程数。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>

using namespace std;

vector<int> vec[1000];
bool visited[1000];
int pre[1000];

bool find(int x)
{
for(int i = 0;i < vec[x].size();i++)
{
int t = vec[x][i];
if(!visited[t])
{
visited[t] = true;
if(pre[t] == 0 || find(pre[t]))
{
pre[t] = x;
return true;
}
}
}

return false;
}

int main()
{
int t;
cin>>t;
while(t--)
{
int p,n;
scanf("%d%d",&p,&n);
for(int i = 1;i <= p;i++)
{
int m;
scanf("%d",&m);
for(int j = 1;j <= m;j++)
{
int s;
scanf("%d",&s);
vec[i].push_back(s);
}
}

memset(pre,0,sizeof(pre));
int ans = 0;
for(int i = 1;i <= p;i++)
{
memset(visited,false,sizeof(visited));
if(find(i))
{
ans++;
}
}

if(ans == p)
{
printf("YES\n");
}
else
{
printf("NO\n");
}

for(int i = 1;i <= p;i++)
{
vec[i].clear();
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: