您的位置:首页 > 其它

Seeding

2015-08-05 15:37 363 查看
Time Limit: 2 Seconds
Memory Limit: 65536 KB

It is spring time and farmers have to plant seeds in the field. Tom has a nice field, which is a rectangle with n * m squares. There are big stones in some of the squares.

Tom has a seeding-machine. At the beginning, the machine lies in the top left corner of the field. After the machine finishes one square, Tom drives it into an adjacent square, and continues seeding. In order to protect the machine, Tom will not drive it
into a square that contains stones. It is not allowed to drive the machine into a square that been seeded before, either.

Tom wants to seed all the squares that do not contain stones. Is it possible?

Input

The first line of each test case contains two integers n and m that denote the size of the field. (1 < n, m < 7) The next n lines give the field, each of which contains m characters. 'S' is a square with stones, and '.' is a square without stones.

Input is terminated with two 0's. This case is not to be processed.

Output

For each test case, print "YES" if Tom can make it, or "NO" otherwise.

Sample Input

4 4

.S..

.S..

....

....

4 4

....

...S

....

...S

0 0



Sample Output


YES

NO

#include<stdio.h>
#include<cstring>
char s[10][10];
int c[10][10];
int a,b,ans;
int n[4]={0,0,1,-1};
int m[4]={1,-1,0,0};
int dfs(int x,int y,int q)
{
if(q==0)
{
return 1;
}
c[x][y]=1;
for(int i=0;i<4;i++)
{
int nx=x+n[i];
int ny=y+m[i];
if(nx<a&&ny<b&&nx>=0&&ny>=0&&c[nx][ny]!=1&&dfs(nx,ny,q-1))
return 1;
}
c[x][y]=0;
return 0;
}
int main()
{
int i,j,k;
while(scanf("%d%d",&a,&b),a|b)
{
for(i=0;i<a;i++)
scanf("%s",s[i]);
int count=0;
for(i=0;i<a;i++)
for(j=0;j<b;j++)
if(s[i][j]=='.')
{
c[i][j]=0;
count++;
}
else c[i][j]=1;

if(dfs(0,0,count-1))
printf("YES\n");
else printf("NO\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: