您的位置:首页 > 其它

集训第四周(高效算法设计)C题 (二分查找优化题)

2015-08-05 14:59 429 查看
Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6639 Accepted Submission(s): 2514


[align=left]Problem Description[/align]
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

[align=left]Input[/align]
One line with a positive integer: the number of test cases. Then for each test case:
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.

[align=left]Output[/align]
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).

[align=left]Sample Input[/align]

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

[align=left]Sample Output[/align]

25.1327
3.1416
50.2655

同样是在一个限值范围中寻找最优值,然后在这个范围中进行二分优化,不过这道题要注意精度的概念,通常如果两个数相差不到10的-6次方,这两个数就可以认为是相等的了

限值是什么?当然是每个人应该得到多大的东西了,不过要注意k要加1,因为主人自己也要一份

#include"iostream"
#include"algorithm"
#include"cstring"
#include"cmath"
#include"cstdio"
#define mi 1e-6
using namespace std;

const double pi=acos(-1.0);
const int maxn=10000+10;

int n,k;
double a[maxn];
double tot;

void Init()
{
cin>>n>>k;
tot=0;
k++;
for(int i=0;i<n;i++)
{
cin>>a[i];
a[i]=pi*a[i]*a[i];
tot+=a[i];
}
}

int need(double num)
{
int c=0;
for(int i=0;i<n;i++) c+=int(a[i]/num);
return c>=k?1:0;
}

void guess()
{
double l,r,m;
l=0;r=tot/k;
while(r-l>mi)
{
m=l+(r-l)/2;
if(need(m)) l=m;
else r=m;
}
printf("%6.4f\n",l);
}

int main()
{
int T;
cin>>T;
while(T--)
{
Init();
guess();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: